Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für Buchhaltung



Excel-Version: 9.0 (Office 2000)

Betrifft: Formel für Buchhaltung
von: Roland
Geschrieben am: 28.05.2002 - 08:13:04

Wer kann mir Helfen, ich bringe es selber nicht fertig?

Ausgangslage:
Auf Blatt 1 ist folgende Buchung: Feld b7 "1000", Feld c7 "2000", Feld c7"1500". Das heisst Konto 1000 an Konto 2000 Fr. 1500.--.
Auf Blatt 2 befinden sich die Konten 1000 und 2000, dargestellt wie folgt: Feld b3 "1000" (Kontobezeichnung), ab Feld b4 Spalte Soll, ab c4 Spalte Haben. Das Konto 2000 Feld e3, Soll ab e4, Haben ab f4.

Jetzt das Problem:
Wie mache ich das, dass es mir in den Konten, wenn die Buchung zutreffend ist, den Betrag auf der Richtigen Seite im Konto einträgt, und zwar so, dass immer das nächste freie Feld unterhalb beschrieben wird?

Auf dem Blatt 1 sind dann mehrer Buchungen untereinander aufgeführt, die dann automatisch den entsprechenden Konten zugeordnet werden sollten.

Ich hoffe, dass mir jemand eine Lösung hat. Im Moment habe ich einfach unötig viele leerzeilen in den Konten.

Merci

  

Re: Formel für Buchhaltung
von: Coach
Geschrieben am: 28.05.2002 - 11:18:34

Hallo Roland,

im Prinzip geht das für das Soll in Spalte B des Kontenblattes mit folgender Arrayformel (Strg+Shift+Enter für die Eingabe)
=WENN(ISTZAHL(KKLEINSTE(WENN(HB!$B$2:$B$10=B$3;ZEILE(HB!$B$2:$B$10));ZEILE()-ZEILE($B$4)));INDEX(HB!$D$1:$D$10;KKLEINSTE(WENN(HB!$B$2:$B$10=B$3;ZEILE(HB!$B$2:$B$10));ZEILE()-ZEILE($B$4));1);"")
und für das Haben
=WENN(ISTZAHL(KKLEINSTE(WENN(HB!$C$2:$C$10=B$3;ZEILE(HB!$C$2:$C$10));ZEILE()-ZEILE($B$4)));INDEX(HB!$D$1:$D$10;KKLEINSTE(WENN(HB!$C$2:$C$10=B$3;ZEILE(HB!$C$2:$C$10));ZEILE()-ZEILE($B$4));1);"")
Die maximale Zeilenzahl der Buchungen im Hauptbuch muß natürlich angepaßt werden. Mit definierten Namen kann man die Formel auch deutlich vereinfachen.

Beispielmappe ist per eMail unterwegs.

Viele Grüße

Coach

  

Re: Formel für Buchhaltung
von: Roland
Geschrieben am: 28.05.2002 - 11:36:17

Danke an Coach für die Lösung.

mfG Roland


 

Beiträge aus den Excel-Beispielen zum Thema "Formel für Buchhaltung"