Verschachtelte Formel



Excel-Version: Alle Versionen
nach unten

Betrifft: Verschachtelte Formel
von: Markus
Geschrieben am: 24.06.2002 - 21:30:01

Habe folgendes problem:

Also ein Student schreibt 3 Klausuren, die je unterschiedliche maximalpunktzahlen haben. nun muss der Student in mindeststens 2 klausuren 67% der maximalpunkte erreichen UND er soll auch noch insgesammt (in den drei Klausuren) 200Punkte haben. Ich habe nun aus den jeweiligen erreichten punkten schon den prozentsatz; und die gesammtpunktzahl ausrechnen lassen. nun habe ich versucht durch verschachtelung von WENN funktionen zu realisieren. habe aber riesige probleme das hinzukriegen. am ende soll nur bestanden oder Durchgefallen ausgegeben werden. wie kann ich das machen; und/oder mit einer anderen funktion besser machen.
thx
Markus

nach oben   nach unten

Re: Verschachtelte Formel
von: th.heinrich
Geschrieben am: 24.06.2002 - 22:08:19

hi Markus,

zeige dem Forum wie Dein ansatz ist, dann kann daran weitergearbeitet werden.

gruss thomas


nach oben   nach unten

Re: Verschachtelte Formel
von: Andreas
Geschrieben am: 24.06.2002 - 22:09:06

Hallo Markus,

also folgende Annahme:
Die MAximalpunktzahlen der 3 Klausuren stehen untereinander in den Zellen A1, A2 und A3. Jeweils danaben in Spalte B stehen die erreichten Punkte.
Dann bestimmt folgende Formel, dass was Du möchtest:
=WENN(ODER(((A1*0,67>B1)+(A2*0,67>B2)+(A3*0,67>B3))>1;(B1+B2+B3)<200);"durchgefallen";"bestanden")

Viel Spaß,
Andreas

nach oben   nach unten

noch ne frage dazu
von: Markus
Geschrieben am: 27.06.2002 - 17:49:34

klasse, hast mir echt geholfen, nur noch ne kleine frage: wie funktioniert genau das:
(((A1*0,67>B1)+(A2*0,67>B2)+(A3*0,67>B3))>1
speziell das >1

Markus

nach oben   nach unten

Re: noch ne frage dazu
von: Andreas
Geschrieben am: 27.06.2002 - 20:43:25

Hallo Markus,

kein Problem. Also es gibt ja 3 Werte die addiert werden.
Alle 3 Terme für sich, sind ja Vergleiche (z.B. (A2*0,67>B2)).
Eigentlich geben diese 3 Terme jeweils WAHR oder FALSCH zurück, je nachdem ob 67% erreicht wurden. Für WAHR und FALSCH gibt Excel aber auch die Dualzahlen 1 bzw. 0 zurück. Somit kann man gleich damit rechnen. Und wenn nun alle 3 Terme für sich entweder zu 0 oder 1 werden, und man diese addiert, so entsteht ja ein Zahl zwischen 0 und 3! Der Vergleich in der Formel mit GRÖßER 1 entspringt ja nun Deiner Aufgabenstellung, wenn bei mehr als 1 Prüfungsteil weniger als 67% der Punkte erreicht wurden, so ist man durchgefallen, d.h:
((A1*0,67>B1)+(A2*0,67>B2)+(A3*0,67>B3))>1 ist dann WAHR!!!

Hoffe das hat weitergeholfen. Wenn Du noch weitere Fragen hast, dann stell sie ruhig!

Viel Spaß,
Andreas

nach oben   nach unten

ich staune o.t.
von: th.heinrich
Geschrieben am: 27.06.2002 - 21:54:40

.

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Verschachtelte Formel"