Formel und Diagramm = 0



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Formel und Diagramm = 0
von: Sabine
Geschrieben am: 01.07.2002 - 23:27:20

Hallo ihr wer kann mir helfen ich habe ein Diagramm wobei die angaben durch eine Formel berechnet werden! Nun wird im Diagramm die Formel als 0 Dargestellt sollte aber als nichts dargestellt werden wie wenn die Formel nicht da stehen würde eine wenn formel geht nicht geht das mit VBA oder einer anderen Lösung bitte um eure Hilfe

MfG
Sabine


nach oben   nach unten

Re: Formel und Diagramm = 0
von: stefan
Geschrieben am: 02.07.2002 - 09:28:30

wie wärs wenn du in der formel noch eine wenn-abfrage einbaust:

wenn(y=true;y;"")

dann steht nichts da falls deine berechnung nicht das gewünschte ergebnis ergibt, es wird dann auch nicht null angezeigt.

nach oben   nach unten

Re: Formel und Diagramm = 0
von: Sabine
Geschrieben am: 02.07.2002 - 09:39:24

Hallo
aber die formel kapier ich jetzt nicht wie muß ich die einbinden.
Meine Formel lautet
=WENN(B10>0;C10/B10;0)
wie ferbinde ich diese mit der
wenn(Y=true,y,"")

nach oben   nach unten

Re: Formel und Diagramm = 0
von: Martin Beck
Geschrieben am: 02.07.2002 - 09:44:13

Hallo Sabine,

welchen Diagrammtyp verwendest Du?

Versuche mal die Formel zu ändern in

=WENN(B10>0;C10/B10;#NV)

Gruß
Martin Beck


nach oben   nach unten

Re: Formel und Diagramm = 0
von: Sabine
Geschrieben am: 02.07.2002 - 09:50:43

Verwende ein Liniendiagramm mit der Formel
=WENN(B10>0;C10/B10;#NV)
Ist es das selbe nur das im Formlefeld #NV steht aer im Diagramm ist es das selbe.

nach oben   nach unten

Re: Formel und Diagramm = 0
von: Martin Beck
Geschrieben am: 02.07.2002 - 10:26:02

Hallo Sabine,

Du mußt mal detaillierter beschreiben, was Du genau machst und was Du eigentlich erreichen willst. Wenn die Bedingung B10>0 erfüllt ist, soll aufgrund der WENN-Formel etwas in eine Zelle eingetragen werden (z.B. 0 oder #NV). Dieser "Wert" soll dann in einem Liniendiagramm dargestellt werden, aber wie?

Die Lösung mit #NV führt dazu, daß dieser Wert "ignoriert" und die Linie durchgezogen wird. Der Wert 0 bewirkt, daß die Linie auf 0 fällt und wieder steil ansteigt (es gibt also einen Zacken). Welche Art der Darstellung möchtest Du erreichen?

Gruß
Martin Beck


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Formel und Diagramm = 0"