suchen und ausgeben

Bild

Betrifft: suchen und ausgeben
von: arwed
Geschrieben am: 22.04.2015 12:14:43

Hallo in die Ferne,
Die Loesung scheint mit sverweis(?) nahe, aber bei mir funktiniert nix richtig.
Problem:
In tabelle 1 im Feld A1 schreibe ich einen Suchbegriff.
In tabelle 2 steht eine Preiliste die in der Spalte B irgendwo diesen Begriff enthaelt.
Ist der Wert in tabelle 2 Spalte B gefunden, so steht der gesuchte wert im Feld Dxx.
Der Wert aus Dxx soll in tabelle 1 im feld b1 ausgegeben werden.
Ich habe die ENGL Version.

Bild

Betrifft: 4.Parameter ?
von: Matthias L
Geschrieben am: 22.04.2015 12:55:51
Hallo
Tabelle2

 BCD
1Suchbegriff10 Wert1
2Suchbegriff9 Wert2
3Suchbegriff8 Wert3
4Suchbegriff7 Wert4
5Suchbegriff6 Wert5
6Suchbegriff5 Wert6
7Suchbegriff4 Wert7
8Suchbegriff3 Wert8
9Suchbegriff2 Wert9
10Suchbegriff1 Wert10
11Suchbegriff0 Wert11


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Tabelle1

 AB
1Suchbegriff1Wert10

Formeln der Tabelle
ZelleFormel
B1=SVERWEIS(A1;Tabelle2!B1:D11;3;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: 4.Parameter ?
von: arwed
Geschrieben am: 22.04.2015 15:44:37
Danke,
irgendwas ist noch falsch...
Die Tabelle 2 heisst INV he, daran sollte es nicht liegen.
Nur in B1 in der die Formel steht, kommt kein Ergebis raus
=vlookup(A1;'INV he'!B1:D11;3;0)

Bild

Betrifft: , statt ;
von: Rudi Maintaire
Geschrieben am: 22.04.2015 16:32:03
Hallo,
dass in engl. Versionen die Parameter mit , getrennt werden, sollte man selbst mit kaum Kenntnissen wissen.
Gruß
Rudi

Bild

Betrifft: AW: suchen und ausgeben
von: arwed
Geschrieben am: 22.04.2015 16:41:28
Danke Rudi,
bist sicher ein ganz toller Hecht und weisst alles viel besser. Ich wuenschte mir von Leuten wie Dir mehr Verstaendnis gegenueber denen die nicht so ein tolles Wissen haben!
Vielleicht koenntest Du ja eine Loesung statt spott praesentieren?
=vlookup(A1,'INV he'!B1:D11,3,0)
funktioniert eben nicht.

Bild

Betrifft: lad doch mal eine Bsp.Mappe hoch ...
von: Matthias L
Geschrieben am: 22.04.2015 16:59:30
Hallo
Mal sehen ob wir den Fehler finden.
Ich vermute einfach mal der Suchbegriff stimmt nicht mit einem Vergleichswert aus der Liste überein.
Prüfe bitte ob es tatsächlich gleich geschrieben ist.
Der Suchbegriff muss gleich des Begriffs in der Suchliste sein.
Wir haben schon oft erlebt, das ein Leerzeichen zu Beginn
oder meist am Ende (weil nicht gleich erkennbar) der Grund dafür sind.
Ansonsten: lad doch bitte eine Bsp.Mappe hoch
Gruß Matthias

Bild

Betrifft: AW: suchen und ausgeben
von: arwed
Geschrieben am: 22.04.2015 17:22:04
Das ist Tabelle "INV he" der Wert der gefunden werden soll steht in B, in D steht der Wert der im anderen Tabellenblatt angezeigt werden soll.
B C D
10447 H10447 2.134
10508 H10508 1.101
10509 H10509 0.9
10512 H10512 1.141
30702 30702 2.55
.
.
.
.
Danke aus Windhoek

Bild

Betrifft: so kann ich nicht helfen, ich bin raus ... owT
von: Matthias L
Geschrieben am: 22.04.2015 17:31:00


Bild

Betrifft: AW: suchen und ausgeben
von: arwed
Geschrieben am: 23.04.2015 09:53:04
DANKE!
=VLOOKUP(A25,'INV he'!B3:D169,3,FALSE)
Funktioniert bestens!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "suchen und ausgeben"