Duplikate verhindern funktioniert nicht richtig..

Bild

Betrifft: Duplikate verhindern funktioniert nicht richtig..
von: Lukas
Geschrieben am: 21.08.2015 08:49:53

Hallo... ich komm nicht weiter.
Es werden mit einem 2D-Scanner, Barcodes gescannt bzw. 9363105030000782515071300289... Duplikate sollen verhindert werden. Das funktioniert soweit!!

Doch wenn bei Datenüberprüfung folgenden Code eintrage : "=ZÄHLENWENN($C$6:$C$85;C6)=1" werden Duplikate verhindert ABER auch nicht-Duplikate, bei denen die letzte Ziffer um eins erhöht ist.... also z.B.
C-Reihe
6. Zeile 9363105030000782515071300289
7. Zeile 9363105030000782515071300290

Beim eintragen des oben-stehenden wird angezeigt dass, das ein Duplikat ist!

Ich hoffe mir kann jemand helfen.. Gerne auch in VBA
Danke im Voraus

Bild

Betrifft: AW: obwohl Ziffernfolgen, sind es Texte ...
von: ... neopa C
Geschrieben am: 21.08.2015 09:24:15
Hallo Lukas,
... und ZÄHLENWENN() geht bei Ziffernfolgen zunächst von Zahlenwerten aus bzw. wandelt diese in solche Excel unterscheidet aber für Zahlenwerte nur bis zu einer Genauigkeit von 15 Stellen somit sind diese Werte für ZÄHLENWENN() identisch. Nicht aber bei SUMMENPRODUKT()
Deshalb: =SUMMENPRODUKT(($C$6:$C$85=C6)*1)=1
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Duplikate verhindern funktioniert nicht richtig.."