Microsoft Excel

Herbers Excel/VBA-Archiv

Bestimmte Wörter zählen


Betrifft: Bestimmte Wörter zählen von: Dirk
Geschrieben am: 20.06.2017 13:46:43

Ich suche eine Formel die ich benutzen kann um bestimmte Wörter in einem Bereich zu zählen.

Z.B. zeige mir wie oft "Heinz Müller" im Bereich A1:A25 zu finden ist. Das zu suchende Wort steht allerdings nicht allein in der Zelle. Countif fällt also flach...

Danke im Voraus,
Dirk

  

Betrifft: AW: Bestimmte Wörter zählen von: SF
Geschrieben am: 20.06.2017 13:48:50

Hola,

glaub ich nicht:

=ZÄHLENWENN(A1:A25;"*heinz müller*")

Gruß,
steve1da


  

Betrifft: AW: Bestimmte Wörter zählen von: Dirk
Geschrieben am: 20.06.2017 14:05:38

Wie blöd bin ich denn...?

DANKE!


  

Betrifft: AW: Bestimmte Wörter zählen von: onur
Geschrieben am: 20.06.2017 14:32:49

Nimm diese selbstgestrickte Funktion (in ein MODUL kopieren):

Public Function ZählenWieOft(ByVal such As String, ByVal Target As Range)
     Dim cell As Range
     Dim x, v, sum
     For Each cell In Target
          v = Split(cell, such)
          If UBound(v) <> -1 Then sum = sum + UBound(v)
     Next
     ZählenWieOft = sum
End Function
Aufruf z.B. so:
=ZählenWieOft("Heinz Müller";A1:A6)



  

Betrifft: AW: warum? wo doch schon ZÄHLENWENN() reicht? owT von: ... neopa C
Geschrieben am: 20.06.2017 14:49:19

Gruß Werner
.. , - ...


  

Betrifft: AW: warum? wo doch schon ZÄHLENWENN() reicht? owT von: onur
Geschrieben am: 20.06.2017 15:17:59

Weil ich beim Uploaden nicht darauf geachtet habe, ob inzwischen schon eine Antwort steht.


  

Betrifft: reicht =ZÄHLENWENN() wirklich? von: ransi
Geschrieben am: 20.06.2017 22:13:56

Hallo,

Nur für den Fall das der gute Heinz Müller mehrfach in einer Zelle vorkommt:
Tabelle1

 AB
1Heinz Müller text Heinz Müller5
2Heinz Müller 
3  
4  
5Heinz Müller text Heinz Müller 
6  
7  

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((LÄNGE(A1:A25)-LÄNGE(WECHSELN(A1:A25;"Heinz Müller";"")))/LÄNGE("Heinz Müller"))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


ransi


Beiträge aus den Excel-Beispielen zum Thema "Bestimmte Wörter zählen"