Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich v. 2 Tabellen / Werte zählen

Betrifft: Vergleich v. 2 Tabellen / Werte zählen von: Martin B.
Geschrieben am: 21.07.2020 11:12:47

Guten Morgen zusammen,


ich habe eine Tabelle 1 mit einer Spalte und ein paar tausend Artikelnummern (alphanumerisch) und eine Tabelle 2 wo Text aus Emails drinsteht. In den Email-Texten können die Artikelnummern aus Tabelle 1 vorkommen und ich möchte zählen wie oft jeder Wert aus Tabelle 1 in den Emails in Tabelle 2 vorkommt. Ich nehme an das ist mit einer Pivot-Tabelle ein leichtes, aber leider habe ich davon überhaupt gar keine Ahnung. Ich wäre für jeden Hinweis sehr dankbar!


Beispiel: https://www.herber.de/bbs/user/139193.xlsx



Grüße,

Martin

Betrifft: AW: Vergleich v. 2 Tabellen / Werte zählen
von: SF
Geschrieben am: 21.07.2020 11:26:31

Hola,
=ZÄHLENWENN(Tabelle2!B:C;"*"&B2&"*")

Gruß,
steve1da

Betrifft: AW: Vergleich v. 2 Tabellen / Werte zählen
von: Martin B.
Geschrieben am: 21.07.2020 12:49:37

Hallo Steve,

vielen Dank für die schnelle Hilfe!

Gruß,
Martin

Betrifft: AW: mit SUMMENPRODUKT() von ZÄHLENWENN() ...
von: neopa C
Geschrieben am: 21.07.2020 11:27:55

Hallo Martin,

... so: =SUMMENPRODUKT(ZÄHLENWENN(Tabelle2!B4:Z999;"*"&B2:B9999&"*")*(B2:B9999>0))

Gruß Werner
.. , - ...

Betrifft: AW: sorry, meine Formel wertet die Summe aller ...
von: neopa C
Geschrieben am: 21.07.2020 11:33:52

Hallo Martin,

... vorkommenden Werte aus Tabelle1 in Tabelle2 aus. Du wolltest jedoch nur die jedes einzelnen Wertes.
Eine Pivotauswertung führt hier nicht zum Ziel. In neueren Excelversionen (Du hast Deine nicht angegben) bestünde als Alternative zu der ZÄHLENWENN()-Formel von Steve evtl. noch eine PowerQuery- Auswertung.

Gruß Werner
.. , - ..

Betrifft: AW: sorry, meine Formel wertet die Summe aller ...
von: Martin B.
Geschrieben am: 21.07.2020 12:50:07

Hallo Werner,

die Summe hilft mir auch. Vielen Dank für die schnelle Hilfe!

Gruß,
Martin

Betrifft: AW: Vergleich v. 2 Tabellen / Werte zählen
von: Michel
Geschrieben am: 21.07.2020 11:28:09

Hi Martin,

leider sind die Artikelnummern in den Mails in zusammenhängenden Texten und teilweise noch mit einem Link hinten dran. Das erschwert die Auswertung, ansonsten könnte man es tatsächlich mit Pivot oder ZÄHLENWENN auswerten.
Hast du die Möglichkeit, die Artikelnummern in den Mails in jeweils nur einer Zelle stehen zu haben?
VG Michel

Betrifft: AW: Vergleich v. 2 Tabellen / Werte zählen
von: Martin B.
Geschrieben am: 21.07.2020 12:50:47

Hallo Michel,

leider nein, aber mittlerweile habe ich eine Lösung bekommen. Vielen Dank für deine Mühe!

Gruß,
Martin

Beiträge aus dem Excel-Forum zum Thema "Vergleich v. 2 Tabellen / Werte zählen "