Microsoft Excel

Herbers Excel/VBA-Archiv

Range aus 2 Tabellen zusammenfassen

Betrifft: Range aus 2 Tabellen zusammenfassen von: Maike Bromann
Geschrieben am: 22.09.2014 12:06:21

Hallo liebe Forengemeinde,

ich habe eine Aufgabe die per Makrorekorder zuviel Aufwand erfordert und möchte fragen wie folgendes per VBA zu lösen wäre. Da ich wenig Erfahrung habe und lernen möchte, wäre ich für eine Kommentierung der Schritte dankbar.

Aus einer Feldforschung sind aus Access 2 Tabellenblätter entstanden:

Im ersten gibt es in Spalte A das Datum numerisch in Spalten B, C und D sind die Hauptkriterien, numerische Werte zwischen 11236 und 14487 in verschiedenem Zusammentreffen. Diese Liste wird laufend mit neuen Werten ergänzt.

In Tabelle 2 gibt es diese Werte 11236 bis 14487 als Überschriften über den Spalten.
In den weiteren vier Zeilen gibt es unlogisch zusammengesetzte numerische Werte zwischen 22 und 120. Diese lassen sich also für die Werte 11236 bis 14487 nicht errechnen.

Nun möchte ich in Tabelle 3 diese Werte konsolidieren, d.h: In Spalte A das Datum als Datum und in Spalte B,C und D Die Werte aus Tabelle 1 Zeile 2 in fett, dann darunter die in den Tabelle 1 vorkommenden variierenden Zusammensetzungen der Zahlen 11236 bis 14487 zugehörigen Werte aus Tabelle 2, Zeile 2 bis 5. Dann der nächste Satz aus Tabelle 1,Zeile 3 und wieder die vier zugehörigen Werte aus Tabelle suchen und die vier Zeilen einfügen.

Ich wäre dankbar dies nicht mehr von Hand tun zu müssen.

  

Betrifft: AW: Range aus 2 Tabellen zusammenfassen von: Rudi Maintaire
Geschrieben am: 22.09.2014 12:52:54

Hallo,
so?

ABCD
122.09.2014121081128714207
2 8910950
3 1145862
4 3034106
5 625745
623.09.2014130681169213428
7 11710842
8 10693104
9 4585117
10 8110858
1124.09.2014115721230914439
12 843930
13 248074
14 6656107
15 5781104

ZelleFormel
A1=INDEX(Tabelle1!A:A;ZEILE(A1)/5+1,8)
B1=INDEX(Tabelle1!B:B;ZEILE(B1)/5+1,8)
C1=INDEX(Tabelle1!C:C;ZEILE(C1)/5+1,8)
D1=INDEX(Tabelle1!D:D;ZEILE(D1)/5+1,8)
B2=WVERWEIS(B1;Tabelle2!$1:$5;2;)
C2=WVERWEIS(C1;Tabelle2!$1:$5;2;)
D2=WVERWEIS(D1;Tabelle2!$1:$5;2;)
B3=WVERWEIS(B1;Tabelle2!$1:$5;3;)
C3=WVERWEIS(C1;Tabelle2!$1:$5;3;)
D3=WVERWEIS(D1;Tabelle2!$1:$5;3;)
B4=WVERWEIS(B1;Tabelle2!$1:$5;4;)
C4=WVERWEIS(C1;Tabelle2!$1:$5;4;)
D4=WVERWEIS(D1;Tabelle2!$1:$5;4;)
B5=WVERWEIS(B1;Tabelle2!$1:$5;5;)
C5=WVERWEIS(C1;Tabelle2!$1:$5;5;)
D5=WVERWEIS(D1;Tabelle2!$1:$5;5;)


Formel in A1 eingeben und nach rechts kopieren.
Formel in B2:B5 eingeben und nach rechts kopieren.
Dann alles nach unten kopieren.

Gruß
Rudi


  

Betrifft: AW: Range aus 2 Tabellen zusammenfassen von: Maike Bromann
Geschrieben am: 22.09.2014 14:09:14

In dieser kurzen Zeit, ich fand kaum Gelegenheit meine Mails zu checken. Dafür zolle ich Dir meinen allergrößten Respekt und werde bei den Unmengen eingesparter Zeit immer mal wieder innerlich Danke dafür sagen.

Gruß Maike


  

Betrifft: AW: Range aus 2 Tabellen zusammenfassen von: Maike Bromann
Geschrieben am: 23.09.2014 11:11:41

Hallo Rudi,

wir haben die Formeln nun mit Dummydaten getestet, und es lief perfect, es gibt nun auch noch eine Überschrift (gedankt sei der schönen Anzeige des Bezugsbereiches in Excel).

Die Formatierungen kriegen wir mit VBA hin, kein Problem.

Falls sich die Anzahl der Zeihlen in Tabelle 2, also die Anzahl der Zeilen mit den varianten Kriterien, zb. auf acht erhöht, muss ich die Formel wie anpassen? Falls dann noch eine Kommentarzeile dazu kommen soll, wie sieht die Formel dann aus?

Wenn ich weiterhin noh etwas erbitten dürfte, wäre dies folgendes:

In einer paralelen Arbeitsgruppe sind die einige Daten bereits händisch ausgewertet worden. Nur diese Auswertungen befinden sich in einem anderen Worksheet in einer Tabelle ab Zeile 5, Spalte 3. Wir möchten bei uns in Tabelle 4 herausfinden ob sich Zeilen aus unserer Tabelle 3 mit deren Zeilen decken, und dafür alle gleichen Zeilen inclusiv Spalten 1 und 2 kopieren.

Das wäre es.

Gruß Maike



  

Betrifft: Beispielmappe? owT von: Rudi Maintaire
Geschrieben am: 23.09.2014 14:28:51




  

Betrifft: AW: Beispielmappe? owT von: Maike Bromann
Geschrieben am: 23.09.2014 18:06:08

Guten Abend Rudi,

ich war tagsüber etwas eingespannt und antworte deshalb so spät. Anbei die 2 Ansichtsmappen.
https://www.herber.de/bbs/user/92777.xlsx und https://www.herber.de/bbs/user/92778.xlsx

Wenn es gelänge identische Datensätze der beiden Tabellen auf Blatt 4 zu schreiben, wäre das die Quintessenz!


  

Betrifft: AW: Beispielmappe? owT von: Maike Bromann
Geschrieben am: 25.09.2014 11:08:42

Hatte den Haken vergessen zu setzen.


 

Beiträge aus den Excel-Beispielen zum Thema "Range aus 2 Tabellen zusammenfassen"