Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Zelle farbig dann

Betrifft: Wenn Zelle farbig dann von: Tom
Geschrieben am: 16.09.2020 08:56:05

Hallo und guten Morgen ins Forum.

Ich habe da mal wieder ein Problem bei dem ich nicht weiter komme.
Ich habe in Spalte A die Monatstage vom 1. Bis zum 31 aufgelistet.
Per bedingter Formatierung färbt sich bei einem Feiertag die entsprechende Zelle

In Spalte B habe ich eine WENN Formel hinterlegt welche einen Wert zurückgibt.
Wie kann ich es umsetzten, dass dieser Wert in B nicht zurück gegeben wird sobald die entsprechende Zelle in A farbig ist?
Ich hoffe ihr könnt mir helfen.

LG Tom

Betrifft: AW: Wenn Zelle farbig dann
von: SF
Geschrieben am: 16.09.2020 08:59:15

Hola,

indem du mit Wenn abfragst, ob die Zelle die Bedingung der bed. Formatierung erfüllt.

Gruß,
steve1da

Betrifft: AW: Wenn Zelle farbig dann
von: Tom
Geschrieben am: 16.09.2020 09:46:10

Hallo steve1da,
erstamal vielen Dank für Deine schnelle Antwort.

Das heißt ich trage in B1 ein
=Wenn(Formel aus der bedingten Formatierung in A1);““;Formel aus B1
Habe ich das so richtig verstanden?

Betrifft: AW: Wenn Zelle farbig dann
von: SF
Geschrieben am: 16.09.2020 09:48:50

Hola,

das hängt von deiner streng geheimen Formel in der bed. Formatierung ab.

Gruß,
steve1da

Betrifft: AW: Wenn Zelle farbig dann
von: Tom
Geschrieben am: 16.09.2020 09:56:29

Ok hab die Schelte verstanden und verdient.
Hier also die Formel aus der bedingten Formatierung in A1

=SVERWEIS(A1;Stammdaten!$F$24:$F$35;1;0)

und hier die Formel aus B1

=WENN(ISTFEHLER(VERGLEICH(C9;Stammdaten!$F$24:$F$35;0));"";8/24)

Betrifft: AW: Wenn Zelle farbig dann
von: SF
Geschrieben am: 16.09.2020 10:07:05

Hola,

zuerst schreibst du dass die Formel in B1 soll, jetzt steht schon eine Formel in B1?
=WENN(ZÄHLENWENN(Stammdaten!$F$24:$F$35;A1)=0;WENNFEHLER(VERGLEICH(C9;Stammdaten!$F$24:$F$35;0); _
8/24);"")
Gruß,
steve1da

Betrifft: AW: Wenn Zelle farbig dann
von: Tom
Geschrieben am: 16.09.2020 10:14:31

Ich möchte, dass die Formel in B1 nicht ausgeführt wir, sobald die Bedingung in A1 erfüllt ist und A1 farblich (über bedingte Formatierung) angepasst wird.
Ist das machbar?

Betrifft: AW: Wenn Zelle farbig dann
von: SF
Geschrieben am: 16.09.2020 10:18:58

Hola,

hast du meine Formel überhaupt mal ausprobiert?

Gruß,
steve1da

Betrifft: AW: Wenn Zelle farbig dann
von: Tom
Geschrieben am: 16.09.2020 10:38:00

Hey Steve, Du bist der Größte.
Vielen vielen Dank, Du hast mir eine Menge Grübeln erspart und ich habe dank Dir wieder etwas dazu gelernt.

Ich wünsche dir einen schönen Tag (der ja heute noch sehr angenhmen sonnig sein soll).

Betrifft: AW: Wenn Zelle farbig dann
von: Tom
Geschrieben am: 16.09.2020 10:46:30

In Reihe 1 hat die Formel wunderbar funktioniert. Ziehe ich die Formel jedoch runter (wo B1 seinen Code ausführen soll, erscheint nur #NAME?
Worauf bezieht sich der gesuchte #NAME und wie muss ich den Code anpassen?

Betrifft: AW: Wenn Zelle farbig dann
von: SF
Geschrieben am: 16.09.2020 11:01:47

Hola,

#NAME bedeutet ein Schreibfehler in der Formel.
Wenn ich die Formel in meiner Datei nach unten ziehe, funktioniert sie hervorragend.

Gruß,
steve1da

Beiträge aus dem Excel-Forum zum Thema "Wenn Zelle farbig dann"