Microsoft Excel

Herbers Excel/VBA-Archiv

eMail aus Excel Dateien verschieben

Betrifft: eMail aus Excel Dateien verschieben von: Jack Stern
Geschrieben am: 24.08.2004 09:20:11

Hi Leutz!

Ich hab ein Kleines Problem mit der Excel-Datei-A und der Excel -Datei-B:

Datei-A hat nur eine lange Spalte Namensliste und Datei-B hat fast die gleiche Spalte Namensliste, nur etwas kleiner und mit einer zusätzlichen Spalte von eMail-Adressen.

Also die Anzahl von Spalte1 aus Datei-A größer als Spalte1 aus Datei-B,
aber die Anzahl von Spalte1 aus Datei-B gleich mit Spalte2 aus Datei-B!

in kurzform halt...

Jetzt wirds kniffelig:

Ich Möchte einen Abgleich zwischen den zweien machen und zwar so, das zum schluss nur noch die lange Namensliste bleibt mit der unvollständig (iss ja klar, wenn die erste Namensliste länger als die Zweite ist) eMail-Adresse zu den Namen zugeordnet (die restlichen muss ich dann also nur noch dann manuell einsetzen).

würde mir helfen wenn einer von euch mir'n tipp gibt.......thx!

  


Betrifft: AW: eMail aus Excel Dateien verschieben von: Jens M
Geschrieben am: 24.08.2004 13:44:05

Hallo Jack!

In Zelle b1 deiner A-Tabelle setzt du ein und kopierst runter bis zur letzten Zeile:

=SVERWEIS(A1;TabelleB!$A$1:$B$100;2;FALSCH)

[Anstatt TabelleB gib deren richtigen Namen ein und für $A$1:$B$100 den Bereich, in dem die Namen mit Emailadressen stehen, die $-Zeichen müssen stehen bleiben]

Ich hoffe, dass ich dich richtig verstanden habe.

Gruß,
Jens


 

Beiträge aus den Excel-Beispielen zum Thema "eMail aus Excel Dateien verschieben"