Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich zweier Tabellenblätter

Betrifft: Vergleich zweier Tabellenblätter von: Nico
Geschrieben am: 27.06.2008 08:59:24

Morjen allerseits!

Ich hätte gerne einen Formeltipp von Euch:

In einer Tabelle bestehend aus Spalten von A bis BN und Zeileninhalten von 8-860 sind in den vergangenen Tagen Datensatzänderungen aufgrund von Rückläufen eingetragen worden. Was ich nun möchte ist folgendes: Suche in dem Tabellenblatt "Alte Daten" die Übereinstimmung von Zelle A8(Firma) & B8(Nachname) und vergleiche alle Datensätze in den Zellen von L8-BN8 mit den im aktuellen Tabellenblatt gemachten Änderungen. Findest Du eine Abweichung, dann trage in das Feld K8 nur ein "Ja" ein.

Mir würde jetzt nur die bedingte Formatierung einfallen, da alles andere, was ich kann zu lanmge dauern würde.

Liebe Grüße und schon einmal vielen Dank!

  

Betrifft: AW: Vergleich zweier Tabellenblätter von: David
Geschrieben am: 02.07.2008 17:23:28

probier's mal so:

=WENN(UND(IDENTISCH(BEREICH.VERSCHIEBEN(alt!C1;SUMMENPRODUKT((alt!A1:A4=A2)*(alt!B1:B4=B2) *ZEILE(alt!A1:A4))-1;0;;ANZAHL2(C2:E2));BEREICH.VERSCHIEBEN(C2;;;;ANZAHL2(C2:E2))))=WAHR;"ja";"nein")

[Als Matrix-Formel eingeben, d.h. mit STRG-SHIFT-ENTER abschließen]

dort wo C:E steht, entsprechend deiner Tabelle anpassen, ebenso natürlich die Zeilen

Ich hänge vorsichtshalber mal meine Testdatei mit an...

https://www.herber.de/bbs/user/53536.xls

Gruß

David


 

Beiträge aus den Excel-Beispielen zum Thema "Vergleich zweier Tabellenblätter"