Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich in zwei Tabellenblättern | Herbers Excel-Forum


Betrifft: Vergleich in zwei Tabellenblättern von: tuska
Geschrieben am: 20.10.2008 00:22:04

Hallo,
ich habe die Forumssuche schon benutzt bitte aber trotzdem um Hilfe bei folgendem Problem, uzw.
Tabellenblatt 1: in Spalte X habe ich den Zellinhalt von Spalten C5&S5 verbunden (Text u. Zahlen)
Tabellenblatt 2: in Spalte AQ habe ich die Zellen B2&AP2 verbunden (Text u. Zahlen), usf.
Danach habe ich versucht, mit der Formel =WENN(ISTFEHLER(SVERWEIS(X5;Tabelle2!$B$2:$AQ$33;40;WAHR));"nicht vorh.";SVERWEIS(X5;Tabelle2!$B$2:$AQ$33;40;WAHR)) einen Vergleich
herzustellen und bei Übereinstimmung den Wert aus der 40. Spalte von Tabellenblatt 2 im Tabellenbl. 1 einzutragen. So eine Frage gab es schon einmal: https://www.herber.de/forum/archiv/412to416/t412208.htm#412208.
Ich wähnte mich schon am Ziel, habe aber dann testweise den Wert in Zelle X5 überschrieben und eigentlich habe ich als Ergebnis "nicht vorhanden" erwartet, jedoch wurde das vorherige Ergebnis nicht verändert und ist nun falsch.
Optimal wäre auch, in einer unsortierten Liste (Parameter FALSCH) zu suchen - hier habe ich leider auch
nicht das richtige Ergebnis erhalten.
Vielleicht weiß jemand einen Rat oder eine andere Lösung. Danke schon im voraus für die Bemühungen.
Gruß
tuska

  

Betrifft: AW: Vergleich in zwei Tabellenblättern von: tuska
Geschrieben am: 20.10.2008 00:47:46

Kann es sein, daß die zu durchsuchende Spalte immer die A - Spalte sein muß?
Gruß
tuska


  

Betrifft: AW: Vergleich in zwei Tabellenblättern von: tuska
Geschrieben am: 20.10.2008 00:49:25

Kann es sein, daß beim SVERWEIS die zu durchsuchende Spalte immer die Spalte A sein muß?
Gruß
tuska


  

Betrifft: AW: Vergleich in zwei Tabellenblättern von: Erich G.
Geschrieben am: 20.10.2008 07:27:59

Hallo Vorname, ( zu Vornamen und Nicknames schau bitte mal in die Forums-FAQ )
zunächst müsstest du für dich klären, wo der Wert gesucht und welcher Wert dann zurückgegeben werden soll.

Tabelle1!X2 soll gesucht werden in Tabelle2!$AQ$2:$AQ$33 (also in Spalte AQ).
Bei einem Treffer soll der Wert aus Tabelle2!$AN$2:$AN$33 (also aus Spalte AN = Spalte 40) zurückgegeben werden.

Habe ich dass so richtig verstanden?
Dann hätte Tabelle2!$B$2 in der Formel wohl nichts zu suchen.

Bei SVERWEIS muss die durchsuchte Spalte (muss nicht Spalte A sein!) links von der Ergebnisspalte sein.
Das ist jetzt bei dir nicht so - AQ ist rechts von AN.

Dann bietet sich an, das mit INDEX und VERGLEICH zu lösen. Probier mal

 Y
1 
2accc

Formeln der Tabelle
ZelleFormel
Y2=WENN(ISTFEHLER(VERGLEICH(X2;Tabelle2!$AQ$2:$AQ$33;0)); "nicht vorh."; INDEX(Tabelle2!$AN:$AN;1+VERGLEICH(X2;Tabelle2!$AQ$2:$AQ$33;0)))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Vergleich in zwei Tabellenblättern von: tuska
Geschrieben am: 20.10.2008 20:59:25

Hallo Erich,
herzlichen Dank für Deine Bemühungen. Ich habe id Zwischenzeit auch nach einer Lösung gesucht.
Ich denke beide Lösungen führen zum selben Ergebnis. Deine Formel verstehe ich leider nicht ganz,
uzw. den Teil mit "... 1+VERGLEICH ..." (also das 1plus ist mir unklar).
Leider hat sich jetzt für mich eine neue Frage aufgetan, uzw. versuche ich ja Daten von Tabelle 2
nach Tabelle 1 zu importieren und das Problem ist das sowohl VERGLEICH als auch SVERWEIS nur
bis zur ersten Fundstelle suchen und diesen Wert ausgeben. Wenn der gesuchte Wert jedoch in einer
geringfügig anderen Kombination vorkommt, dann wird nicht mehr zugegriffen. Siehe jeweils Tabelle 2,
Zellen A2 u. D2 bzw. A5 u. D5 (der Schlüsselbegriff ABC123 hat einmal den Wert XXX u. einmal Wert ZZZ.)
Um das Problem zu verdeutlichen lade ich 2 Excel-Tabellen (VERGLEICH=Deine Lösung; SVERWEIS=mein Lösungsversuch mit Suche im Forum). Ich bitte Dich nochmals zu prüfen, ob man hier mit einer Funktion
noch etwas machen kann oder ob hier nur mehr ein Makro Abhilfe schaffen kann. (Makros programmieren
kann ich nicht). Danke!
Gruß
Karl


  

Betrifft: AW: Vergleich in zwei Tabellenblättern von: tuska
Geschrieben am: 20.10.2008 21:08:12

Sorry, hier sind die Dateien...
https://www.herber.de/bbs/user/56154.xls
https://www.herber.de/bbs/user/56155.xls
Gruß
Karl


  

Betrifft: AW: Vergleich in zwei Tabellenblättern von: Erich G.
Geschrieben am: 21.10.2008 00:43:21

Hi Karl,
eine Formel dafür findest du bei http://www.excelformeln.de/formeln.html?welcher=28
Sie muss aber ein wenig umgestrickt werden.

Wo sollen die Mehrfachtreffer den hingeschrieben werden? Ich hab hier mal max. 3 Treffer in den Spalten D:F vorgesehen:
(In Spalte D kannst du die SVERWEIS- oder die INDEX-Formel verwenden.)

Tabelle1

 ABCDEF
1SchlüsselTextZahlWerte  
2ABC123ABC123XXXWWWOOO
3DEF456DEF456YYY  
4GHJ789GHJ789ZZZ  
5GGG777GGG777nicht vorh.  

Formeln der Tabelle
ZelleFormel
A2=B2&C2
D2=WENN(ISTFEHLER(VERGLEICH(A2;Tabelle2!$A$2:$A$5;0)); "nicht vorh."; SVERWEIS(A2;Tabelle2!$A$2:$D$6;4;0))
E2{=WENN(SPALTEN($A:B)>ZÄHLENWENN(Tabelle2!$A$2:$A$6;$A2); ""; INDEX(Tabelle2!$D$2:$D$6;KKLEINSTE(WENN(Tabelle2!$A$2:$A$6=$A2;ZEILE($1:$5)); SPALTE(B1))))}
F2{=WENN(SPALTEN($A:C)>ZÄHLENWENN(Tabelle2!$A$2:$A$6;$A2); ""; INDEX(Tabelle2!$D$2:$D$6;KKLEINSTE(WENN(Tabelle2!$A$2:$A$6=$A2;ZEILE($1:$5)); SPALTE(C1))))}
D3{=WENN(SPALTEN($A:A)>ZÄHLENWENN(Tabelle2!$A$2:$A$6;$A3); ""; INDEX(Tabelle2!$D$2:$D$6;KKLEINSTE(WENN(Tabelle2!$A$2:$A$6=$A3;ZEILE($1:$5)); SPALTE(A2))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Tabelle2

 ABCD
2ABC123ABC123XXX
3DEF456DEF456YYY
4ABC123ABC123WWW
5GHJ789GHJ789ZZZ
6ABC123ABC123OOO

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Vergleich ... - kleine Korrektur von: Erich G.
Geschrieben am: 21.10.2008 00:48:17

Hi Karl,
bei der Formel in D2 war der Bereich für VERGLEICH nicht korrekt.
So muss die Formel lauten:

=WENN(ISTFEHLER(VERGLEICH(A2;Tabelle2!$A$2:$A$6;0)); "nicht vorh."; SVERWEIS(A2;Tabelle2!$A$2:$D$6;4; 0)) 


Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Vergleich ... - kleine Korrektur von: tuska
Geschrieben am: 21.10.2008 17:29:20

Hallo Erich,
danke für Deine umfangreichen Bemühungen und die Lösungsformeln. Sie funktionieren ausgezeichnet!
(Ich werde jedoch noch eine Weile benötigen um sie zu verstehen.)
Herzlichen Gruß
Karl


Beiträge aus den Excel-Beispielen zum Thema "Vergleich in zwei Tabellenblättern"