Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis mit Mittelwert ungefähr finden

Betrifft: Sverweis mit Mittelwert ungefähr finden von: Daniel
Geschrieben am: 15.07.2008 16:27:57

Hallo Profis,

ich würde gerne ein Suchkriterium in einer Spalte finden und via sverweis zurückgeben. Dies ist kein Problem.

In der Spalte, in der gesucht wird, ist allerdings nicht genau das Suchkriterium abgebildet, sondern eine Zeichenfolge, welche das SK enthält.

Dies funktioniert auch mit dem sverweis.

Jetzt würde ich aber gerne den Mittelwert aller Zellen zurückgeben, in denen in der Suchspalte das Suchkriterium im Text enthalten ist.

Bei genauer Übereinstimmung von Suchkriterium und der Spalte in der man suchte für folgende Array-Formel funktionieren:

{=MITTELWERT(WENN(Tabelle1!K2:K10=B1;Tabelle1!W2:W10))}
~f~

Also, Bsp:

Suchkriterium: PQR

Spalte1 Spalte 2
hdgsfjh 1
dfkj 1
fusdhfiu 2
jhdfPQRdf 4
sdfsdPQR 8

~f~
Nun soll als Ergebnis 4+8=12 -> 12/2 = 6 herauskommen.

Ist dies irgendwie möglich?

Vielen dank vorab.

Daniel

  

Betrifft: AW: Sverweis mit Mittelwert ungefähr finden von: Mustafa
Geschrieben am: 15.07.2008 16:29:35

Hey Daniel,

die frage wurde doch eben schon beantwortet.

https://www.herber.de/forum/messages/993798.html

So machst du dir in diesem Forum keine Freunde.

Gruß aus Köln.


 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis mit Mittelwert ungefähr finden"