Formelbezug



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Formelbezug
von: Andreas
Geschrieben am: 17.06.2002 - 21:53:20

Hallo,

kann mir jemand weiterhelfen?

Ich habe in der zelle A1 diese Formel stehen: =Wochentag(B1)
Diese ist als TTT formatiert.
In die Zelle B1 gebe ich ein datum ein.
In der Zelle A1 zeigt er mir dann Mo oder Di usw.
was auch richtig ist.
wenn ich jetzt aber in der zelle C1 die Formel eingebe:
=wenn(A1="Mo";"ok";"nicht ok") zeigt er mir immer nicht ok an,
obwohl in A1 Mo steht. Wenn ich aber die Formel:
=wenn(A1="=Wochentag(B1)";"ok";"nicht ok") eingebe, zeigt er mir ok an.
Er bezieht sich irgendwie auf die Formel in A1 und nicht auf das Ergebniss.

Danke im voraus

Andreas

nach oben   nach unten

Re: Formelbezug
von: Ramses
Geschrieben am: 17.06.2002 - 22:11:28

Hallo Andreas,

das ist korrekt, weil das Ergebnis deiner Formel in A1 eine Zahl ist und nur durch die Formatierung "Montag" oder andere Tage anzeigt.

Die korrekte Formel für A1 lautet übrigens:
=WOCHENTAG(B1;2)
Mit 2 weist du EXCEL an die europäsiche Zählweise zu verwenden und dort ist 1 der Montag, bei deiner Formel wird 1 als Sonntag angezeigt, weil das amerikanische Format verwendet wird.

Die Formel in C1 lautet dann:

=WENN(A1 = 1;"Montag";"Anderer Tag")

Gruss Rainer

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "F - Tasten"