Formellösung



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Formellösung
von: Joachim S
Geschrieben am: 20.06.2002 - 11:47:14

In folgender Tabelle möchte ich, daß bei Eingabe des Suchkriterium aus den linken Spalten entsprechen des Kriteriums die Namen ausgesucht werden und rechts von oben nach unten ohne Leerzeile eingetragen werden!

MS Excel von Joachim S
 ABCDEF
1      Suchkriterium 
2      Jungen 
3KategorieVornameName  VornameName
4JungenMichaA  MichaA
5MädchenBeaB  DanielE
6SchülerFloriC  LazloF
7SchülerinnenKathaD  GünterG
8JungenDanielE   
9SchülerinnenSabineH   
10SchülerinnenMartinaI   
11SchülerinnenIsaJ   
12SchülerThomasK   
13SchülerReinerL   
14SchülerBerndM   
15JungenLazloF   
16JungenGünterG   

Ich hoffe mir kann jemand helfen.
Schöne Grüße vom Bodensee
Josi

nach oben   nach unten

Re: Formellösung
von: Andreas
Geschrieben am: 20.06.2002 - 13:02:57

Hallo Josi,

also genau für Dein angebenes Beispiel folgende Formeln:
in Zelle E4:
=WENN(ZÄHLENWENN(A4:A16;$D$2)>0;SVERWEIS($D$2;A4:B16;2;0);"")
In Zelle F4:
=WENN(ISTNV(SVERWEIS(E4;$B$4:$C$16;2;0));"";SVERWEIS(E4;$B$4:$C$16;2;0))
in Zelle E5:
=WENN(ZÄHLENWENN($A$4:$A$16;$D$2)>ZEILE()-4;SVERWEIS($D$2;INDIREKT("A"&VERGLEICH(E4;B:B;0)+1&":B16");2;0);"")

Die Formeln in F4 und in E5 einfach soweit runterziehen (kopieren) wie benötigt.

Viel Spaß,
Andreas

nach oben   nach unten

Re: Formellösung
von: Joachim S
Geschrieben am: 20.06.2002 - 13:40:31

Ich hab das jetzt auf meine Mappe umgebaut
und man staunt es klappt wunderbar!!
Wenn ich auch keinen Schimmer habe was ich da gemacht habe!!!
Ich frag mich wie man man auf solche Formelgebilde kommen kann!!

Vielen Dank
das war super:-)

Gruß Josi

nach oben   nach unten

Re: Formellösung
von: Andreas
Geschrieben am: 20.06.2002 - 13:50:12

Hallo Josi,

wenn Du die Formeln umbaust, mußt Du aber ganz schön aufpassen.
So wild sind die Formeln nun nicht, bis auf die untere vielleicht. Aber lösen kann man sowas, wie alle anderen Probleme auch. Das Motto: "Zerlege ein Problem solange in Teilprobleme bis diese lösbar sind und setze dann alles zusammen"

Achso noch ein kleiner Hinweis, Probleme mit diesen Formeln können auftreten, wenn Namen mehrfach auftreten!!! Wenn das der Fall ist, dann wirds etwas komplizierter!

Viel Spaß,
Andreas

nach oben   nach unten

Re: Formellösung
von: Joachim S
Geschrieben am: 20.06.2002 - 14:03:24

Hallo Andreas genau dieser Fall tritt ein es werden Namen doppelt sein :-(
nach oben   nach unten

Re: Formellösung
von: Andreas
Geschrieben am: 20.06.2002 - 16:07:40

Hallo Josi,

hab nun eine neue Lösung, viel einfacher, dank Hilfsspalte:

Also sie ist noch mal für Dein gepostetet Beispiel gedacht:

Formel in Zelle E4:
=WENN(ISTFEHLER(INDEX(B:B;G4));"";INDEX(B:B;G4))

Formel in Zelle F4:
=WENN(ISTFEHLER(INDEX(C:C;G4));"";INDEX(C:C;G4))

Formel in Zelle G4 (Hilfspalte):
=VERGLEICH(D2;A1:A16;0)

Formel in Zelle G5:
=VERGLEICH($D$2;INDIREKT("A"&G4+1&":A16");0)+G4

So die Formeln in den Zellen E4, F4,G5 kannst Du einfach runterziehen! Die Hilfsspalte kannst Du ausblenden, dort habe ich auch keine Fehlerbehandlung integriert!

Viel Spaß,
Andreas

nach oben   nach unten

Re: Formellösung
von: Joachim S
Geschrieben am: 20.06.2002 - 17:11:57

Hallo Andreas
Jetzt ist es genau dass was ich brauchte
es funktioniert bestens!

Vielen Dank:-)

Gruß Josi

nach oben   nach unten

Re: Formellösung
von: Hans W. Hofmann
Geschrieben am: 21.06.2002 - 18:13:04

Hallo ihr beide,

warum gebt ihr euch eigentlich soviel Mühe festvorgegebene Funktionen, wie Daten | Spezialfilter nachzustellen.
Formellösungen für typische Abfragen von Daten haben immer den Nachteil, dass man vorher wissen muss wieviele Formeln man benötigt - von der Mühe ganz zu schweigen. Also Spezialfilter rein und habe fertig, der wird auch mit Dupletten fertig...

Gruß HW


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Vergleich"