Excel-Suche in VB



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Excel-Suche in VB
von: Anna
Geschrieben am: 24.06.2002 - 17:51:10

Hallo,

ich möchte eine Spalte mit der Excel-Suche durchsuchen.

(Gründe:
-Es muß eine bestimmte Spalte sein, weil der gefundene Wert auch evtl. woanders steht, es aber Fehler verursachen würde, wenn er dort gefunden würde
-Ich habe in dieser Spalte Formeln und will in Werten suchen und habe keine Ahnung, wie man das in einem VB-Script definiert;-))

Wenn er den Wert gefunden hat, möchte ich mit diesem Range-Objekt weiterarbeiten, weil ich in der betreffenden Zeile auf Werte aus anderen Spalten zugreifen will.
Z.B. möchte ich einen Wert haben, der 5 Zellen rechts von dem gefundenen ist.

Wie kann ich das nun machen, daß ich die gefundene Zelle in eine Variable einlese und dann auf Ihre Range-Eigenschaften zugreifen kann und mit ihnen "rechnen" kann, so wie bei Range(1,0), Range(1,0+i)?

Grüße,
Anna

nach oben   nach unten

Re: Excel-Suche in VB
von: Steffen
Geschrieben am: 24.06.2002 - 18:36:21

Mal ne kleine Formel als Anregung:

=WENN(ISTFEHLER(SVERWEIS(C2;A:B;2));BEREICH.VERSCHIEBEN(INDEX(B:B;VERGLEICH(C2;B:B;0);1);0;-1);SVERWEIS(C2;A:B;2))

nach oben   nach unten

Re: Excel-Suche in VB
von: Anna
Geschrieben am: 25.06.2002 - 08:31:16

Ich verstehe leider nicht, was Du meinst.
Es ist jedenfalls so, daß ich den Eintrag eben nur in der einen Spalte finden will, wenn er woanders in der Tabelle steht, interessiert er mich nicht.
Eine Formel nutzt mir nichts.

Übrigens, die korrekte Antwort wäre gewesen:
Set Zelle = Selection.Find(...)
Zelle.Select
und dann mit Offset() arbeiten,

aber das habe ich ja dann selbst herausgefunden;-)

Grüße,
Anna

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Nicht Drucken von Mustern in Zellen"