Wert aus Tabelle filtern und verrechnen

Bild

Betrifft: Wert aus Tabelle filtern und verrechnen
von: BBB
Geschrieben am: 24.07.2015 10:57:51

Hallo zusammen,
ich habe eine Wertetabelle (s. Anhang https://www.herber.de/bbs/user/99048.xlsx
). Nun möchte ich gerne mit einer Formel die Werte in Spalte E so miteinander verrechnen, dass A1 bis A3 immer gleich sind und wenn A4 größer 0 der jeweilige Wert aus Spalte E mit dem verrechnet wird, bei dem A4=0 ist.
Kann man das verstehen?
Zum besseren Verständnis habe ich das in den ersten Zeilen mal händisch eingetragen. Da die Werte aber anders sortiert sein können, würde ich das gerne automatisch vergleichen und berechnen lassen.
Für Tips bin ich dankbar!
Grüße, BBB

Bild

Betrifft: z.B. mit Hilfe von AGGREGAT() ...
von: der neopa C
Geschrieben am: 24.07.2015 11:19:42
Hallo,
... und Formel ziehend nach unten kopieren (ich ging davon aus, das Du auch die "#WERT!" Fehlermeldung nicht sehen möchtest):

 ABCDEF
1A1A2A3A4Wert 
21110505,1417 
31120332,2886 
41130503,1828 
51111510,21641,010046
61121338,68351,019245
71131513,57311,020649

Formeln der Tabelle
ZelleFormel
F2=WENNFEHLER(E2/INDEX(E:E;AGGREGAT(15;6;ZEILE(A$1:A2)/(A$1:A2=A2)/(B$1:B2=B2)/(C$1:C2=C2)/(D$1:D2=0); 1))/(D2>0); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: z.B. mit Hilfe von AGGREGAT() ...
von: BBB
Geschrieben am: 24.07.2015 12:11:33
wow, ich habs zwar noch nicht nachvollzogen, aber scheint zu funktionieren. Vielen Dank!!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wert aus Tabelle filtern und verrechnen"