Microsoft Excel

Herbers Excel/VBA-Archiv

Ohne VBA: Wenn Autofilter, dann anderen Zellwert | Herbers Excel-Forum


Betrifft: Ohne VBA: Wenn Autofilter, dann anderen Zellwert von: sunni
Geschrieben am: 08.01.2010 12:17:23

Hallo alle zusammen,

gibt es eine Möglichkeit über Excel (ohne VBA) zu sehen, ob ein Autofilter gesetzt ist?
Hintergrund: ich habe eine Formel bei gesetztem Autofilter. Wenn aber kein Autofilter gesetzt ist, soll hier in der Zelle eine 0 oder "" erscheinen.

Geht das?

Vielen Dank schon einmal für die Hilfe
sunni

  

Betrifft: AW: Ohne VBA: Wenn Autofilter, dann anderen Zellwert von: Daniel
Geschrieben am: 08.01.2010 12:35:47

Hi

du könntest die Funktion "Teilergebnis" mit der Option "Anzahl2" nutzen, denn Teilergebnis berücksichtigt nur die sichtbaren Zellen:

=Wenn(Teilergebnis(3;A:A)=Anzahl2(A:A);"alle Daten";"Filter aktiv")

allerdings solltest du diese Funtkion auf eine Spalte anwenden, die keine Leerzellen enthält, da diese von Anzahl2 nicht gezählt werden und so ein falsches Ergebnis liefern könnten, falls Leerzellen ausgeblendet werden.

Gruß, Daniel


  

Betrifft: AW: Ohne VBA: Wenn Autofilter, dann anderen Zellwert von: sunni
Geschrieben am: 08.01.2010 13:29:40

super!!

Ich habe die Formel von Daniel genommen, war schön kurz und ich habe sie verstanden :-)) uuunnnddd..
sie funktioniert!!

Danke aber auch an alle anderen für die Mühe zur Beantwortung meiner Frage.
sunni


  

Betrifft: AW: Ohne VBA: Wenn Autofilter, dann anderen Zellwert von: Ramses
Geschrieben am: 08.01.2010 14:20:11

Hallo

Dann musst du nur sicherstellen, dass keine Leerzellen in deiner Datenbank sind.
Meine Formel funktioniert auch mit Leerzellen ;-)

Gruss Rainer


  

Betrifft: AW: naja, eine ordentliche Datenbank von: Daniel
Geschrieben am: 08.01.2010 15:58:08

sollte zumindest in einer Spalte keine Leerzellen aufweisen.
Gruß, Daniel


  

Betrifft: AW: Ohne VBA: Wenn Autofilter, dann anderen Zellwert von: Ramses
Geschrieben am: 08.01.2010 12:35:49

Hallo

Vielleicht gehts auch anders, aber auf die Schnelle

Tabelle2

 ABCDEF
1NameVorname ErgebnisFilter gesetzt 
2a1    
4c3    
6e5    
7      

Formeln der Tabelle
ZelleFormel
E1{=WENN(ZEILE(INDIREKT(ADRESSE(MAX(WENN(A2:A1000<>"";ZEILE(2:1000))); MAX(WENN(A2:A1000<>"";SPALTE(A:A))); 4)))=TEILERGEBNIS(3;A2:A1000)+1;"Kein Filter";"Filter gesetzt")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Bezüge allenfalls anpassen

Gruss Rainer


  

Betrifft: AW: Ohne VBA: Wenn Autofilter, dann anderen Zellwert von: ransi
Geschrieben am: 08.01.2010 12:36:56

HAllo

DAs sind deine Daten:
Tabelle3

 ABCDEFG
1Daten1Daten2Daten3  Gefiltert ? FALSCH 
2474735    
351299    
4426797    
5936222    
665331    
7939520    
866239    
985331    
10641149    
11345083    
1269290    
13569131    
14516139    
1524753    
16962494    
17157858    
1882848    
19171974    
20476091    
21865434    
2264865    
23334456    
2416924    
25834775    
26100991    
2734804    
28642977    
2914216    
30717486    
3133108    
32391932    
33323371    
3417385    
35178955    
36322162    
37       

Formeln der Tabelle
ZelleFormel
F1="Gefiltert ? " & (TEILERGEBNIS(3;A:C)<>ANZAHL2(A:C))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Jetzt filter mal ein bischen in der Tabelle...

ransi


  

Betrifft: Wenn Autofilter, dann ... von: Erich G.
Geschrieben am: 08.01.2010 12:44:19

Hi,
vielleicht auch mit xl4-Funktion? Nachteil: Es erfolgt keine automatische Neuberechnung.

 ABCD
1dasdsadf  
219  
328 30
437  

Formeln der Tabelle
ZelleFormel
D3=WENN(AutoF;SUMME(A:B); 0)
Namen in Formeln
ZelleNameBezieht sich auf
D3AutoF=DATEI.ZUORDNEN(86;"Tabelle1")

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


Beiträge aus den Excel-Beispielen zum Thema "Ohne VBA: Wenn Autofilter, dann anderen Zellwert"