Formel liefert zu hohen Wert

Bild

Betrifft: Formel liefert zu hohen Wert
von: Tobias
Geschrieben am: 07.03.2005 12:27:37

Ich zähle bestimmte Zellen, wenn eine Bedingung wahr ist. Die Formel
=(SUMMENPRODUKT(ZÄHLENWENN(Unfallliste!$L$21:$Q$70;Unfallliste!L11)*(Unfallliste!$X$21:$X$70=WAHR)))
liefert aber einen viel zu hohen Wert (Faktor 2). Hat da jemand eine Idee?
Grüße tobias

Bild

Betrifft: Lass das ZÄHLENWENN weg...
von: Boris
Geschrieben am: 07.03.2005 12:36:58
Hi Tobias,
=SUMMENPRODUKT((Unfallliste!$L$21:$Q$70=Unfallliste!L11)*(Unfallliste!$X$21:$X$70=WAHR))
Grüße Boris
Bild

Betrifft: Hoppla - ist ja ein mehrspaltiger Bereich...
von: Boris
Geschrieben am: 07.03.2005 12:38:48
Hi Tobias,
$L$21:$Q$70 - hatte ich überlesen. Schilder mal genau, was wann gezählt werden soll.
Grüße Boris
Bild

Betrifft: AW: Lass das ZÄHLENWENN weg...
von: Toibas
Geschrieben am: 07.03.2005 12:50:39
Super!
Danke
Bild

Betrifft: AW: Lass das ZÄHLENWENN weg...
von: ingoG
Geschrieben am: 07.03.2005 13:14:03
Hallo Tobias,
die formel rechnet wenn ich mich richtig erinnere nur dann korrekt, wenn in einer Zeile L:Q nur einmal der Wert L11 vorkommt. Sollte er 2x vorhanden sein wird auch 2 mal gezählt.
ansonsten versuchs mal mit:
=SUMMENPRODUKT((zählenwenn(Unfallliste!$L$21:$Q$70;Unfallliste!L11)>0)*(Unfallliste!$X$21:$X$70=WAHR))
kanns leider nicht testen, aber nach meinem Verständis sollte es funzen...
Gruß Ingo
Bild

Betrifft: Das funktioniert nicht...
von: Boris
Geschrieben am: 07.03.2005 14:11:12
Hi Ingo,
denn ZÄHLENWENN liefert hier EIN statisches Ergebnis - und damit wird jedes WAHR aus X21:X70 multipliziert.
Grüße Boris
Bild

Betrifft: AW: Das funktioniert nicht...
von: ingoG
Geschrieben am: 07.03.2005 20:55:06
Hallo Boris,
jetzt wo du's sagst erinnere ich mich, auch schon mal probleme damit gehabt zu haben.
habs glaub ich damals mit einer kombination aus indirekt und zählenwenn gelöst...
zb
=SUMMENPRODUKT((ZÄHLENWENN(INDIREKT("A"&ZEILE(A1:A10)&":D"&ZEILE(A1:A10));"x")>0)*(E1:E10))
liefert die summe aller werte in e1:e10 zurück, die mindestens ein "x" in der selben Zeile in den spalten a-d stehen haben.
die Formel
=SUMMENPRODUKT((a1:d10="x")*(E1:E10))
würde den wert in spalte e für jedes x addieren, dh also bis zu 4 mal, wenn alle werte in spalte a-d="x" sind...
Gruß Ingo
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel liefert zu hohen Wert"