Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
988to992
988to992
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Vergleichen von Tabellen

Vergleichen von Tabellen
02.07.2008 08:53:00
Tabellen
hey leute
ich weiß bitte nicht zwei beträge zum gleichen thema, sorry aber ich bin bereits seit sonntag
an diesem thema mit tino dran, ganz toll wie er mir hilft, aber wir finden bisher nicht die lösung.
es ist auch aus meiner erfahrung sehr ungewöhnlich das niemand weiteres zu diesem problem
schreibt.
da ich heute den ganzen tag am pc bin wollte ich nochmal um hilfe rufennnnnnnnnnn.
danke für euer verständniss.
lieben danl ben

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
wenn schon eine neuer Thread ...
02.07.2008 09:59:18
neopa
Hallo Ben,
... dann fasse doch bitte Deine Aufgabenstellung und evtl. bereits erhaltene Hinweise neu zusammen
Gruß Werner
.. , - ...
p.S. Allerdings komme ich persönlich nicht vor heute Nachmittag dazu, es mir es anzusehen.

AW: wenn schon eine neuer Thread ...
02.07.2008 13:02:45
Ben
https://www.herber.de/bbs/user/53524.xls
hey werner, habe das beispiel nochmal hier reingestellt.
der fehler ist grün unterlegt.
bis dann
danke für deine antwort ;-)
ben
weitere notizen zu desem problem noch bei offenen fragen vom 30.06.

die Datenstruktur solltest Du überdenken, ...
02.07.2008 15:11:04
neopa
Hallo Ben,
... denn zu welchen Problemen diese führt, solltest Du spätestens bei Deiner und Tinos Auswertung gemerkt haben.
Aber es kommt noch schlimmer, selbst mit einer korrekter Auswertung Deiner vorhandenen Datenstruktur kannst Du in Tabelle3 nie auf 93 Auslieferungen kommen, sondern nur auf 85. Das zu erkennen hat mich mehr Zeit gekostet, als ich investieren wollte) Es wurde offensichtlich was geliefert, was gar nicht bestellt war. (Das kommt allerdings öfters vor als man denkt ;-))
Sieh Dir dazu mal Deine Daten in Zeile 85-102 der Tabelle 2 an. Diese wirst Du in Tabelle 1 nicht finden.
Unabhängig von der Datenerfassung, hier nun mein pragmatischer Lösungsvorschlag mit Formeln und Hilfsspalten (Formeln einfach nach unten kopieren):
Tabelle2

 CDEFGHIJKL
9     Auslieferung  Hilfsspalten
10200040petrol1,00193  200040petrol1
11200034rot1,001   200034rot1
12200036rot1,001   200036rot1
13200038rot1,001   200038rot1
14200336rot1,001   200336rot1
15200340rot1,001   200340rot1
16200340schwarz1,001   200340schwarz1

Formeln der Tabelle
ZelleFormel
H10=SUMME(G10:G102)
K10=C10&D10&E10
L10=ZÄHLENWENN(K$10:K10;K10)


Tabelle3

 CDEFGHIJKLWXY
9Bestellungen233     Auslieferung Hilfsspalten
10200040petrol11200040petrol185 200040petrol1
11200034rot11200034rot1  200034rot1
12200036rot11200036rot1  200036rot1
13200038rot11200038rot1  200038rot1
14200336rot11200336rot1  200336rot1
15200340rot11200340rot1  200340rot1
16200340schwarz11200340schwarz1  200340schwarz1

Formeln der Tabelle
ZelleFormel
F9=SUMME(F10:F995)
H10=WENN($K10;C10;"")
I10=WENN($K10;D10;"")
J10=WENN($K10;E10;"")
K10=--ISTZAHL(VERWEIS(9;1/((Tabelle2!K$10:K$999=X10)*(Tabelle2!L$10:L$999=Y10)); Tabelle2!G$10:G$999))
L10=SUMME(K:K)
X10=C10&D10&E10
Y10=ZÄHLENWENN(X$10:X10;X10)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Anzeige
AW: die Datenstruktur solltest Du überdenken, ...
02.07.2008 18:59:00
Ben
hey werner
das sieht spitzzzzzzzzzzzzzeeeeeeee aus.
ich bin immer wieder glücklich das es dieses forum gibt.
aber das hat mich geschockt mit der fehllieferung und du hast recht gehabt.
meine antwort hat etwas gedauert da ich erstmal rumprobiert habe.
werde jetzt glücklich daran weiterarbeiten.
dicken gruß
ben

freut mich auch ...
02.07.2008 19:14:35
neopa
Hallo Ben,
... wenn es Dir weitergeholfen hat. Bei evtl. Rückfragen ... bin zumindest morgen nicht online.
Gruß Werner
.. , - ...

301 Forumthreads zu ähnlichen Themen


Hallo zusammen,
..habe mal wieder eine Blockade im Hirn und suche hier Unterstützung, Anregungen und/oder Ideen...
Folgende Herausforderung (Musterdatei liegt hier bei):
Ich habe eine Adressen-Liste und muss es aus statistischen Gründen in Gruppen zusammenfassen. Soll heißen, alle "...
Anzeige

Hallo,
ich habe zwei Tabellen.
Die erste Tabelle ist eine Liste mit ca. 20.000 Datensätzen, die Daten nach Ortsschlüssel, Produktnummer und Vertriebsweg enthalten.
Die zweite Tabelle ist eine Kreuztabelle mit Referenzwerten nach Produktnummer und Vertriebsweg. Die Produktnummern ste...

https://www.herber.de/bbs/user/55577.xls
https://www.herber.de/bbs/user/55576.xls
Hallo,
ich möchte die beiden Tabellen aufgrund des darin enthaltenen Area Code vergleichen. Wichtig ist dabei ob sich die Tabelle 55577 gegenüber der Tabelle 55576 verändert hat, wichtig ist ob sich e...
Anzeige

Hallo zusammen,
Leider habe ich keine Ahnung von VBA und soll 2 Tabllenblätter zeilenweise miteinander vergleichen.
Wenn der Inhalt der Zeile 1 A1-P1 (Tabelle1) mit dem Inhalt der 1. Zeile A1-P1 (Tabelle 2) übereinstimmen, soll mit der Prüfung der 2. Zeile fortgefahren werden. Ansonsten...

Hallo,
ich habe die Forumssuche schon benutzt bitte aber trotzdem um Hilfe bei folgendem Problem, uzw.
Tabellenblatt 1: in Spalte X habe ich den Zellinhalt von Spalten C5&S5 verbunden (Text u. Zahlen)
Tabellenblatt 2: in Spalte AQ habe ich die Zellen B2&AP2 verbunden (Text u...

Hallo liebe Experten,
ich stehe gerade vor einem, für mich etwas komplexeren, Problem. Ich denke aber, dass es für euch mit Sicherheit kein Problem darstellt.
Ich habe in einer Tabelle zwei Spalten (A + B). Jede der beiden Spalten kann den Wert "active" oder "on hold" haben. Die länge d...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige