Matrixformel f. Summenberechnung



Excel-Version: Formel
nach unten

Betrifft: Matrixformel f. Summenberechnung
von: Chris
Geschrieben am: 29.04.2002 - 20:28:12

Habe da ein Problem mit der Berechnung einer Summe über mehrere Zellen.
=SUMME(WENN(C3:C6="tex"+UND(WENN(D3:D6="5"));E3:E6))
Das Problem ist der Vergleich mit den Zellen D3:D6. Hier habe ich in 2 Zellen die 5 stehen. Excel scheint mir dies nicht anzunehmen und zeigt mir einen Fehler.
Wie kriege ich Excel dazu, dass er die Summe von E3:E6 für die Zellen macht, in denen davor in D3:D6 eine 5 steht.
nach oben   nach unten

Re: Matrixformel f. Summenberechnung
von: Otto
Geschrieben am: 29.04.2002 - 20:45:01

Hallo Chris, wenn ich dich richtig verstanden habe, dann brauchst du folgende Formel: =WENN(UND(ODER(C3="tex";C4="tex";C5="tex";C6="tex");ODER(D3=5;D4=5;D5=5;D6=5));SUMME(E3:E6);"") Du kannst nicht einen Bereich = Text oder Zahl setzen z.B. C3:C6="tex" oder D3:D6=5 setzen. Gruß Otto

nach oben   nach unten

Re: Matrixformel f. Summenberechnung
von: Arnim
Geschrieben am: 29.04.2002 - 20:57:01

Hallo Chris, ich nehme an, daß in E3:E6 Zahlen stehen. Schreibe folgende Array-Formel: =SUMME((C3:C6="tex")*(D3:D6=5)*SUMME(E3:E6)) Eingabe mit Strg/Shift/Enter oder: =SUMMENPRODUKT((C3:C6="tex")*(D3:D6=5)*SUMME(E3:E6)) Eingabe nur mit Enter. Gruß Arnim

nach oben   nach unten

Re: Matrixformel f. Summenberechnung
von: Chris
Geschrieben am: 29.04.2002 - 21:00:31

Danke erst einmal für die Hilfestellung. Allerdings funktioniert der erste Teil C3:C6="tex" richtig, da ich bei mehreren Zeilen (100 oder so) nicht jede einzelne Zelle in der Fromel berücksichtigen kann?! Bsp: =SUMME(WENN((B3:B8="A")*(C3:C8="tex");D3:D8)) Dies funktioniert! Aber: =SUMME(WENN((B3:B8="A")*(C3:C8="tex")*(D3:D8="5");E3:E8)) Dies funktioniert nicht, obwohl ich eigentlich nur eine Bedingung hinzugefügt habe!

nach oben   nach unten

Re: Matrixformel f. Summenberechnung
von: Otto
Geschrieben am: 04.05.2002 - 18:02:33

Hallo Chris,
kannst du vielleicht erstmal mich aufklären, was diese Formel überhaupt tut "=SUMME(WENN((B3:B8="A")*(C3:C8="tex");D3:D8))"? Besonders diese "*" Zeichen. Ich kenne so eine Funktion nicht.

Gruß Otto

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Matrixformel f. Summenberechnung"