Excel Automation



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Excel Automation
von: Wilfried Baumann
Geschrieben am: 13.05.2002 - 11:58:15

Excel Automation Problem

(Excel 2000, Automation von Access 2000, Windows 2000 Professional)

Mittels Automation wird Spalte X formatiert:

...
objActiveWkb.Worksheets(1).Range("X:X").NumberFormat = "#,##0.00"
objActiveWkb.Worksheets(1).Range("X:X").HorizontalAlignment = xlRight
...

Einstellung der horizontalen Ausrichtung funktioniert.
Einstellung des Tausendertrennzeichens funktioniert nicht.
Einstellung des Dezimaltrennzeichens funktioniert nur teilweise.


Das Ergebnis sieht so ähnlich aus:
Saldo-EUR
-224107,39
-14243,97
-13030,46
-3228,9
-45136,95
-3648,51
-4971,6
-3404,26
...

Man beachte das fehlende Tausenderternnzeichen (".").
Man beachte das fehlende "0" zb in -3228,9 (sollte sein: -3228,90).

Eine manuelle Überprüfung des Formats der Zellen innerhalb von
Excel ergibt, dass das Format gesetzt wurde, aber Excel zeigt
es nicht an.

Wenn man F2 und Enter drückt dann ist die Anzeige dieser
Zelle plötzlich richtig!

Genau diese Codezeilen funktionierten mit anderen Dateien.

Für jede Anregung wäre ich sehr dankbar!
Grüsse, Wilfried Baumann

nach oben   nach unten

Re: Excel Automation
von: Otto
Geschrieben am: 13.05.2002 - 13:14:13

Hallo Wilfried,

hast Du mal gecheckt, ob die Daten evtl. als Text hereinkommen?
In diesem Falle hilft Dir die Zahlenformatierung nichts.

Gruß
Otto


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Externe Daten per VBA abfragen"