Microsoft Excel

Herbers Excel/VBA-Archiv

Mal wieder Farben zählen | Herbers Excel-Forum


Betrifft: Mal wieder Farben zählen von: Michael
Geschrieben am: 27.10.2008 13:54:54

Hallo zusammen,

ich habe ein kleines Problem beim Farbenzählen und hoffe, ihr könnt mir weiterhelfen.

Ich muss in einer Tabelle 2 Zellen miteinander vergleichen (IST und SOLL Datum). Ist das IST-Datum größer als das SOLL Datum, dann soll IST Datum Rot werden ansonsten Grün. Und dann möchte ich gerne zählen, wieviel Rote und Grüne Zellen ich habe. Am einfachsten würde das ja gehen über eine Bedingte Formatierung aber wie ich hier so gelesen habe, klappt dann leider das Zählen der Farbwerte nicht.

Also habe ich auf einem seperaten Tabellenblatt die beiden Zellen subrahiert (Spalte B). Die Spalte, in der das Ergebnis dann erscheinen (Spalte C ) habe ich als Textfarbe Grün gewähllt. Die Zellen sind als Zahl formatiert und negative Werte sollen Rot dargestellt werden (über Zellen formatieren--Zahlen--Zahl--Negative Werte:.
So weit so gut. Wenn ich jetzt aber über - Einfügen, Namen, Definieren: "Schriftwert"; bezieht sich auf: =ZELLE.ZUORDNEN(24;INDIREKT("ZS(-1)";FALSCH)) die Farbwerte anzeigen lassen möchte, dann bekomm ich immer nur den Wert der grünen Werte angezeigt (=4). Die negativen Werte werden zwar Rot dargestellt, jedoch ändert sich der Wert der Farbe nicht sondern bleibt auf 4 stehen, obwohl hier doch eigentlich 3 stehen müsste oder?? Auch ein drücken von F9 ändert nichts.

Jemand ne Idee, was ich da noch machen könnte??
Danke.

Gruss..Micha

  

Betrifft: AW: Mal wieder Farben zählen von: Beverly
Geschrieben am: 27.10.2008 14:08:50

Hi Micha,

weshalb zählst du nicht einfach mittels ZÄHLENWENN() in deiner Ausgangstabelle die Werte die größer bzw. kleiner sind? Dazu benötigst du doch nicht die Farbe der Zelle.


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Mal wieder Farben zählen von: JogyB
Geschrieben am: 27.10.2008 14:13:17

Mach doch das Einfärben über die bedingte Formatierung und das Zählen mit einer Matrixformel (Beispiel: Ist in A2:A33, Soll in B2:B33)

{=SUMME(WENN(A2:A33>B2:B33;1;0))}

Die {} nicht mit eingeben, sondern die Formel mit Strg + Shift + Eingabe abschliessen.

Gruss, Jogy


  

Betrifft: AW: Mal wieder Farben zählen von: Michael
Geschrieben am: 27.10.2008 14:57:58

Hi Jogy u Karin,

irgendwie krieg ich das net hin. Steh bestimmt aufm Schlauch irgendwo.
Wenn ich Zählenwenn mache, muss ich ja auch ein Kriterium angeben (oder?), was ich aber nicht habe.
Die Inhalte der Zellen sehe so aus:

tt.mm.jjj hh:mm:ss

Hier = SOLL Wert_____________Hier = IST Wert________________Ergebnis = Größer JA/NEIN
01.16.2008 10:05:49________01.08.2008 00:00:00________________Nein (=grün)
01.16.2008 10:10:54________02.11.2008 13:28:31________________JA (=rot)

Könntet ihr mir vl ein kleines Beispiel geben??
Danke

Gruss..Micha


  

Betrifft: 1 Zeile tiefer .... von: heikoS
Geschrieben am: 27.10.2008 15:13:58

Hallo Michael,

guckst Du eine Zeile tiefer in Deinem Thread, da findest Du ein Beispiel.


Gruß Heiko


  

Betrifft: AW: Mal wieder Farben zählen von: Beverly
Geschrieben am: 27.10.2008 15:21:08

Hi Michael,

ich meinte das so

Tabellenblattname: Tabelle1
 

A

B

C

1

Soll

Ist

 

2

01.10.2008 10:05:49

01.08.2008 00:00:00

Nein

3

01.10.2008 10:10:54

02.11.2008 13:28:31

Ja

4

01.10.2008 10:06:01

07.08.2008 10:10:00

Nein

5

01.10.2008 10:06:21

15.10.2008 13:25:00

Ja

6

01.01.2008 10:06:39

16.10.2008 17:20:25

Ja

7

 

 

 

8

 

Erfüllt:

3

9

 

Nichtrfüllt:

2


Benutzte Formeln:
C2: =WENN(A2>B2;"Nein";"Ja")
C3: =WENN(A3>B3;"Nein";"Ja")
C4: =WENN(A4>B4;"Nein";"Ja")
C5: =WENN(A5>B5;"Nein";"Ja")
C6: =WENN(A6>B6;"Nein";"Ja")
C8: =ZÄHLENWENN(C2:C6;"Ja")
C9: =ZÄHLENWENN(C2:C6;"Nein")




GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Mal wieder Farben zählen von: JogyB
Geschrieben am: 27.10.2008 15:28:14

Hallo.

(ich nehme das jetzt mal als Spalten A/B/C und Wertebereich Zeile 2-100 an).

Wenn Du es schon so hast, dann kannst Du das Zählen auch mit ~f~=ZÄHLENWENN($C2:$C100;"JA") erledigen. Wenn Du auf die Hilfsspalte verzichten willst, dann kannst Du meine Formel aus dem vorigen Beispiel verwenden (Du mußt allerdings aus dem > ein < machen, da die Spalten vertauscht sind).

Zur bedingten Formatierung:
Bedingung 1:
=($A2<$B2)
Formatierung rot

Bedingung 2:
=($A2>=$B2)
Formatierung grün

Gruss, Jogy


  

Betrifft: nicht die Farben zählen von: heikoS
Geschrieben am: 27.10.2008 14:34:08

Hallo Michael,

ich würde nicht kompliziert versuchen, die Farben zu zählen, sondern die Ursachen, die zur Farbe führen. Hier ´mal zwei Vorschläge von mir:

Tabelle1

 ABC
1PlanIstErgebnis
2131
3220
4561
51090
6 Summe:2
7 {Summe}:2

Formeln der Tabelle
ZelleFormel
C2=--(B2>A2)
C3=--(B3>A3)
C4=--(B4>A4)
C5=--(B5>A5)
C6=SUMME(C2:C5)
C7{=SUMME(--(B2:B5>A2:A5))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Klappt´s?


Gruß Heiko


  

Betrifft: AW: nicht die Farben zählen von: Michael
Geschrieben am: 27.10.2008 15:16:48

Hallo Heiko,

jupp, hat geklappt. Was macht eigentlich dieses -- vor der Klammer genau??

Gruss..Micha


  

Betrifft: AW: nicht die Farben zählen von: JogyB
Geschrieben am: 27.10.2008 15:33:34

Der Ausdruck in der Klammer ergibt eigentlich WAHR oder FALSCH. Wahr kann auch als 1 und FALSCH als 0 interpretiert werden, das macht Excel hier aber nicht von alleine. Das -- macht nicht anderes als *(-1)*(-1) und damit aus dem WAHR eine 1 und aus FALSCH eine 0. Du kannst stattdessen auch 1* schreiben, das führt zum selben Ergebnis.

Gruss, Jogy


  

Betrifft: AW: nicht die Farben zählen von: Michael
Geschrieben am: 27.10.2008 15:45:37

Aha, danke. Wieder was gelernt.

Gruss..Micha


  

Betrifft: AW: nicht die Farben zählen von: Michael
Geschrieben am: 27.10.2008 15:20:50

Hiho, ich nochmal:-)

Da ja jede Woche (mal mehr, mal weniger) neue IST und SOLL Werte dazukommen, gibts ne möglichkeit, das Ganze auch dynamisch irgendwie zu händeln??

Danke

Gruss.Micha


Beiträge aus den Excel-Beispielen zum Thema "Mal wieder Farben zählen"