Microsoft Excel

Herbers Excel/VBA-Archiv

Zahlen vergleichen und Kosten addieren | Herbers Excel-Forum


Betrifft: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:17:44

Guten Tag an alle,

Ich habe mal wieder ein Problem, dass ich nicht lösen kann:



Ich habe Spalte A= Materialnummer, B= ArbPlatz, R= Einzelkosten und S= Gesamtkosten. Dort hätte ich gerne eine Formel, welche alle Einzelkosten, derselben Materialnummer berechnet. Mit SummeWenn habe ich es versucht, aber auch keine Lösung gefunden.

Über Hilfe wurde ich mich riesig freuen!!
Vielen Dank im Voraus

Melanie

  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Hajo_Zi
Geschrieben am: 29.01.2010 11:22:07

Hallo Melanie,

ich benutze schon Version 2010, aber selbst diese Version kann aus einem Bild keine Tabelle erstellen. Du hast die Zeit für die Erstellung schon investiert, warum müssen wir das nochmal?

GrußformelHomepage


  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:34:37

Hallo Hajo,

ich habe dieses Add-in installiert, weiß aber nicht wie es benutzen kann.


  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:38:25

Tabelle1 A B R S T
1 Material ArbPlatz Einzelkosten Gesamtkosten
2
3 1130000091 1211001 95,35 € 166,02 €
4 1130000091 1215001 70,67 €
5 1130000093 1211001 95,35 € 166,02 €
6 1130000093 1215001 70,67 €
7 1130000171 1217501 139,50 € 210,17 €
8 1130000171 1215001 70,67 €
9 1130000279 1217001 24,08 € 44,25 € 155,42 €
10 1130000279 1215501 20,17 € 111,17 €
11 1130000279 1218001 91,00 €
12 1130000286 1211501 107,25 € 177,92 €
13 1130000286 1215001 70,67 €
14 1130000294 1211501 95,35 € 166,02 €

verwendete Formeln
Zelle Formel
R3 =SUMME(Q3+O3+M3)
S3 =WENN(A3=A4;R3+R4;"")
R4 =SUMME(Q4+O4+M4)
S4 =WENN(A4=A5;R4+R5;"")
R5 =SUMME(Q5+O5+M5)
S5 =WENN(A5=A6;R5+R6;"")
R6 =SUMME(Q6+O6+M6)
S6 =WENN(A6=A7;R6+R7;"")
R7 =SUMME(Q7+O7+M7)
S7 =WENN(A7=A8;R7+R8;"")
R8 =SUMME(Q8+O8+M8)
S8 =WENN(A8=A9;R8+R9;"")
R9 =SUMME(Q9+O9+M9)
S9 =WENN(A9=A10;R9+R10;"")
T9 =S9+S10
R10 =SUMME(Q10+O10+M10)
S10 =WENN(A10=A11;R10+R11;"")
R11 =SUMME(Q11+O11+M11)
S11 =WENN(A11=A12;R11+R12;"")
R12 =SUMME(Q12+O12+M12)
S12 =WENN(A12=A13;R12+R13;"")
R13 =SUMME(Q13+O13+M13)
S13 =WENN(A13=A14;R13+R14;"")
R14 =SUMME(Q14+O14+M14)
S14 =WENN(A14=A15;R14+R15;"")


  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:39:48


Tabelle1

 ABRST
1MaterialArbPlatz Einzelkosten Gesamtkosten  
2         
311300000911211001 95,35 € 166,02 €  
411300000911215001 70,67 €    
511300000931211001 95,35 € 166,02 €  
611300000931215001 70,67 €    
711300001711217501 139,50 € 210,17 €  
811300001711215001 70,67 €    
911300002791217001 24,08 € 44,25 € 155,42 €
1011300002791215501 20,17 € 111,17 €  
1111300002791218001 91,00 €    
1211300002861211501 107,25 € 177,92 €  
1311300002861215001 70,67 €    
1411300002941211501 95,35 € 166,02 €  

verwendete Formeln
Zelle Formel
R3 =SUMME(Q3+O3+M3)
S3 =WENN(A3=A4;R3+R4;"")
R4 =SUMME(Q4+O4+M4)
S4 =WENN(A4=A5;R4+R5;"")
R5 =SUMME(Q5+O5+M5)
S5 =WENN(A5=A6;R5+R6;"")
R6 =SUMME(Q6+O6+M6)
S6 =WENN(A6=A7;R6+R7;"")
R7 =SUMME(Q7+O7+M7)
S7 =WENN(A7=A8;R7+R8;"")
R8 =SUMME(Q8+O8+M8)
S8 =WENN(A8=A9;R8+R9;"")
R9 =SUMME(Q9+O9+M9)
S9 =WENN(A9=A10;R9+R10;"")
T9 =S9+S10
R10 =SUMME(Q10+O10+M10)
S10 =WENN(A10=A11;R10+R11;"")
R11 =SUMME(Q11+O11+M11)
S11 =WENN(A11=A12;R11+R12;"")
R12 =SUMME(Q12+O12+M12)
S12 =WENN(A12=A13;R12+R13;"")
R13 =SUMME(Q13+O13+M13)
S13 =WENN(A13=A14;R13+R14;"")
R14 =SUMME(Q14+O14+M14)
S14 =WENN(A14=A15;R14+R15;"")

Tabellendarstellung in Foren Version 5.5




  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Hajo_Zi
Geschrieben am: 29.01.2010 11:40:07

Hallo Melanie,

Bereich markieren, es ist ein neues Register entstanden, HTML_Anzeige und darunter gibt es 3 Schalter
1. Schalter erstellen, erstellt den HTML Code für das Forum, einfch mit Strg+C in den Beitrag kopieren
2. Schalter wandelt die Tabelle aus dem Forum wieder zurück in eine Tabelle, Teil im Forum kopieren und in eine Tabelle einfügen
3. Schalter Hilfe, da ist es noch ausführlich beschrieben.

Wenn wir jetzt vom gleichen Add In schreiben.

Statistik

 C
2488

verwendete Formeln
Zelle Formel
C2 =INDIREKT(ADRESSE(ZEILE();SPALTE()+8))-INDIREKT(ADRESSE(ZEILE();SPALTE()+7))

Tabellendarstellung in Foren Version 5.5



Gruß Hajo


  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:44:27


Tabelle1

 ABRST
1MaterialArbPlatz Einzelkosten Gesamtkosten  
2         
311300000911211001 95,35 € 166,02 €  
411300000911215001 70,67 €    
511300000931211001 95,35 € 166,02 €  
611300000931215001 70,67 €    
711300001711217501 139,50 € 210,17 €  
811300001711215001 70,67 €    
911300002791217001 24,08 € 44,25 € 155,42 €
1011300002791215501 20,17 € 111,17 €  
1111300002791218001 91,00 €    
1211300002861211501 107,25 € 177,92 €  
1311300002861215001 70,67 €    
1411300002941211501 95,35 € 166,02 €  

verwendete Formeln
Zelle Formel
R3 =SUMME(Q3+O3+M3)
S3 =WENN(A3=A4;R3+R4;"")
R4 =SUMME(Q4+O4+M4)
S4 =WENN(A4=A5;R4+R5;"")
R5 =SUMME(Q5+O5+M5)
S5 =WENN(A5=A6;R5+R6;"")
R6 =SUMME(Q6+O6+M6)
S6 =WENN(A6=A7;R6+R7;"")
R7 =SUMME(Q7+O7+M7)
S7 =WENN(A7=A8;R7+R8;"")
R8 =SUMME(Q8+O8+M8)
S8 =WENN(A8=A9;R8+R9;"")
R9 =SUMME(Q9+O9+M9)
S9 =WENN(A9=A10;R9+R10;"")
T9 =S9+S10
R10 =SUMME(Q10+O10+M10)
S10 =WENN(A10=A11;R10+R11;"")
R11 =SUMME(Q11+O11+M11)
S11 =WENN(A11=A12;R11+R12;"")
R12 =SUMME(Q12+O12+M12)
S12 =WENN(A12=A13;R12+R13;"")
R13 =SUMME(Q13+O13+M13)
S13 =WENN(A13=A14;R13+R14;"")
R14 =SUMME(Q14+O14+M14)
S14 =WENN(A14=A15;R14+R15;"")

Tabellendarstellung in Foren Version 5.5




  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Hajo_Zi
Geschrieben am: 29.01.2010 11:52:35

Hallo Melanie,

du hast jetzt leider nicht die Spalten gepostet auf die sich die Werte beziehen. Darum sind bei mir die Formel durch Werte ersetzt.

Tabelle1

 ABRS
1MaterialArbPlatzEinzelkostenGesamtkosten
2       
31130000091121100195,35 €166,02 €
41130000091121500170,67 € 
51130000093121100195,35 €166,02 €
61130000093121500170,67 € 
711300001711217501139,50 €210,17 €
81130000171121500170,67 € 
91130000279121700124,08 €135,25 €
101130000279121550120,17 € 
111130000279121800191,00 € 
1211300002861211501107,25 €177,92 €
131130000286121500170,67 € 
141130000294121150195,35 €95,35 €

verwendete Formeln
Zelle Formel
S3 =WENN(ZÄHLENWENN($A$3:A3;A3)=1;SUMMENPRODUKT((A3:A14=A3)*R3:R14);"")
S4 =WENN(ZÄHLENWENN($A$3:A4;A4)=1;SUMMENPRODUKT((A4:A15=A4)*R4:R15);"")
S5 =WENN(ZÄHLENWENN($A$3:A5;A5)=1;SUMMENPRODUKT((A5:A16=A5)*R5:R16);"")
S6 =WENN(ZÄHLENWENN($A$3:A6;A6)=1;SUMMENPRODUKT((A6:A17=A6)*R6:R17);"")
S7 =WENN(ZÄHLENWENN($A$3:A7;A7)=1;SUMMENPRODUKT((A7:A18=A7)*R7:R18);"")
S8 =WENN(ZÄHLENWENN($A$3:A8;A8)=1;SUMMENPRODUKT((A8:A19=A8)*R8:R19);"")
S9 =WENN(ZÄHLENWENN($A$3:A9;A9)=1;SUMMENPRODUKT((A9:A20=A9)*R9:R20);"")
S10 =WENN(ZÄHLENWENN($A$3:A10;A10)=1;SUMMENPRODUKT((A10:A21=A10)*R10:R21);"")
S11 =WENN(ZÄHLENWENN($A$3:A11;A11)=1;SUMMENPRODUKT((A11:A22=A11)*R11:R22);"")
S12 =WENN(ZÄHLENWENN($A$3:A12;A12)=1;SUMMENPRODUKT((A12:A23=A12)*R12:R23);"")
S13 =WENN(ZÄHLENWENN($A$3:A13;A13)=1;SUMMENPRODUKT((A13:A24=A13)*R13:R24);"")
S14 =WENN(ZÄHLENWENN($A$3:A14;A14)=1;SUMMENPRODUKT((A14:A25=A14)*R14:R25);"")

Tabellendarstellung in Foren Version 5.5



Gruß Hajo


  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:45:12


Tabelle1

 ABRST
1MaterialArbPlatz Einzelkosten Gesamtkosten  
2         
311300000911211001 95,35 € 166,02 €  
411300000911215001 70,67 €    
511300000931211001 95,35 € 166,02 €  
611300000931215001 70,67 €    
711300001711217501 139,50 € 210,17 €  
811300001711215001 70,67 €    
911300002791217001 24,08 € 44,25 € 155,42 €
1011300002791215501 20,17 € 111,17 €  
1111300002791218001 91,00 €    
1211300002861211501 107,25 € 177,92 €  
1311300002861215001 70,67 €    
1411300002941211501 95,35 € 166,02 €  

verwendete Formeln
Zelle Formel
R3 =SUMME(Q3+O3+M3)
S3 =WENN(A3=A4;R3+R4;"")
R4 =SUMME(Q4+O4+M4)
S4 =WENN(A4=A5;R4+R5;"")
R5 =SUMME(Q5+O5+M5)
S5 =WENN(A5=A6;R5+R6;"")
R6 =SUMME(Q6+O6+M6)
S6 =WENN(A6=A7;R6+R7;"")
R7 =SUMME(Q7+O7+M7)
S7 =WENN(A7=A8;R7+R8;"")
R8 =SUMME(Q8+O8+M8)
S8 =WENN(A8=A9;R8+R9;"")
R9 =SUMME(Q9+O9+M9)
S9 =WENN(A9=A10;R9+R10;"")
T9 =S9+S10
R10 =SUMME(Q10+O10+M10)
S10 =WENN(A10=A11;R10+R11;"")
R11 =SUMME(Q11+O11+M11)
S11 =WENN(A11=A12;R11+R12;"")
R12 =SUMME(Q12+O12+M12)
S12 =WENN(A12=A13;R12+R13;"")
R13 =SUMME(Q13+O13+M13)
S13 =WENN(A13=A14;R13+R14;"")
R14 =SUMME(Q14+O14+M14)
S14 =WENN(A14=A15;R14+R15;"")

Tabellendarstellung in Foren Version 5.5




  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:41:49


Tabelle1

 ABRST
1MaterialArbPlatz Einzelkosten Gesamtkosten  
2         
311300000911211001 95,35 € 166,02 €  
411300000911215001 70,67 €    
511300000931211001 95,35 € 166,02 €  
611300000931215001 70,67 €    
711300001711217501 139,50 € 210,17 €  
811300001711215001 70,67 €    
911300002791217001 24,08 € 44,25 € 155,42 €
1011300002791215501 20,17 € 111,17 €  
1111300002791218001 91,00 €    
1211300002861211501 107,25 € 177,92 €  
1311300002861215001 70,67 €    
1411300002941211501 95,35 € 166,02 €  

verwendete Formeln
Zelle Formel
R3 =SUMME(Q3+O3+M3)
S3 =WENN(A3=A4;R3+R4;"")
R4 =SUMME(Q4+O4+M4)
S4 =WENN(A4=A5;R4+R5;"")
R5 =SUMME(Q5+O5+M5)
S5 =WENN(A5=A6;R5+R6;"")
R6 =SUMME(Q6+O6+M6)
S6 =WENN(A6=A7;R6+R7;"")
R7 =SUMME(Q7+O7+M7)
S7 =WENN(A7=A8;R7+R8;"")
R8 =SUMME(Q8+O8+M8)
S8 =WENN(A8=A9;R8+R9;"")
R9 =SUMME(Q9+O9+M9)
S9 =WENN(A9=A10;R9+R10;"")
T9 =S9+S10
R10 =SUMME(Q10+O10+M10)
S10 =WENN(A10=A11;R10+R11;"")
R11 =SUMME(Q11+O11+M11)
S11 =WENN(A11=A12;R11+R12;"")
R12 =SUMME(Q12+O12+M12)
S12 =WENN(A12=A13;R12+R13;"")
R13 =SUMME(Q13+O13+M13)
S13 =WENN(A13=A14;R13+R14;"")
R14 =SUMME(Q14+O14+M14)
S14 =WENN(A14=A15;R14+R15;"")

Tabellendarstellung in Foren Version 5.5




  

Betrifft: AW: Zahlen vergleichen und Kosten addieren von: Melanie
Geschrieben am: 29.01.2010 11:43:40


Tabelle1

 ABRST
1MaterialArbPlatz Einzelkosten Gesamtkosten  
2         
311300000911211001 95,35 € 166,02 €  
411300000911215001 70,67 €    
511300000931211001 95,35 € 166,02 €  
611300000931215001 70,67 €    
711300001711217501 139,50 € 210,17 €  
811300001711215001 70,67 €    
911300002791217001 24,08 € 44,25 € 155,42 €
1011300002791215501 20,17 € 111,17 €  
1111300002791218001 91,00 €    
1211300002861211501 107,25 € 177,92 €  
1311300002861215001 70,67 €    
1411300002941211501 95,35 € 166,02 €  

verwendete Formeln
Zelle Formel
R3 =SUMME(Q3+O3+M3)
S3 =WENN(A3=A4;R3+R4;"")
R4 =SUMME(Q4+O4+M4)
S4 =WENN(A4=A5;R4+R5;"")
R5 =SUMME(Q5+O5+M5)
S5 =WENN(A5=A6;R5+R6;"")
R6 =SUMME(Q6+O6+M6)
S6 =WENN(A6=A7;R6+R7;"")
R7 =SUMME(Q7+O7+M7)
S7 =WENN(A7=A8;R7+R8;"")
R8 =SUMME(Q8+O8+M8)
S8 =WENN(A8=A9;R8+R9;"")
R9 =SUMME(Q9+O9+M9)
S9 =WENN(A9=A10;R9+R10;"")
T9 =S9+S10
R10 =SUMME(Q10+O10+M10)
S10 =WENN(A10=A11;R10+R11;"")
R11 =SUMME(Q11+O11+M11)
S11 =WENN(A11=A12;R11+R12;"")
R12 =SUMME(Q12+O12+M12)
S12 =WENN(A12=A13;R12+R13;"")
R13 =SUMME(Q13+O13+M13)
S13 =WENN(A13=A14;R13+R14;"")
R14 =SUMME(Q14+O14+M14)
S14 =WENN(A14=A15;R14+R15;"")

Tabellendarstellung in Foren Version 5.5




Beiträge aus den Excel-Beispielen zum Thema "Zahlen vergleichen und Kosten addieren"