Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl der Zellen mit *

Betrifft: Anzahl der Zellen mit * von: Gallanz
Geschrieben am: 16.11.2012 16:14:38

Hallo,

gibt es eine Möglichkeit alle Zellen mit einem * am Ende zu zählen?

Zellen sehen wie folgt aus:

1,3452*
1,3247**
1,3214***

Da die Sternchen Signifikanzniveaus darstellen, können keine anderen Symbole verwendet werden. Kann ich trotzdem die Anzahl der Zellen mit *,** und *** herausfinden?

Gallanz

  

Betrifft: AW: Anzahl der Zellen mit * von: Christian
Geschrieben am: 16.11.2012 17:00:52

Hallo Gallanz,

wenn die Zahl vor dem Sternchen immer gleich lang ist dann:

http://excelformeln.de/formeln.html?welcher=219

MfG Christian


  

Betrifft: AW: Anzahl der Zellen mit * von: CitizenX
Geschrieben am: 16.11.2012 17:05:09

Hi,

wenn der Bereich nicht zu groß ist dann so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
11,3452*3
21,3247** 
31,1254 
41,3214*** 

ZelleFormel
B1{=SUMME(ISTZAHL(FINDEN("*";A1:A4))*1)}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.0) erstellt. ©Gerd alias Bamberg


Grüße
Steffen


  

Betrifft: =SUMMENPRODUKT((RECHTS(A1:A99)="*")*1) von: WF
Geschrieben am: 16.11.2012 17:11:24

.


  

Betrifft: ZÄHLENWENN von: Erich G.
Geschrieben am: 16.11.2012 17:13:02

Hi,
probier mal

 AB
11,3452*8
21,3214***3
31,3247**2
41,3214*** 
5  
6X,***,** 
71,3214***,** 
8*,** 
91,3247** 
101,3452x 

Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN(A$1:A$10;"*~*")
B2=ZÄHLENWENN(A$1:A$10;"*~*,~*~*")
B3=ZÄHLENWENN(A$1:A$10;"*~*~*~*")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: ZÄHLENWENN von: Gallanz
Geschrieben am: 16.11.2012 17:29:19

Hallo,

die Lösung von Erich G. passt am besten (auch wenn B1 alle Zellen mit * zählt)

Danke
Gallanz


  

Betrifft: AW: ZÄHLENWENN von: Erich G.
Geschrieben am: 16.11.2012 18:05:13

Hi,
danke für deine Rückmeldung!

B1 ist die Antwort auf "gibt es eine Möglichkeit, alle Zellen mit einem * am Ende zu zählen?" :-)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl der Zellen mit *"