Microsoft Excel

Herbers Excel/VBA-Archiv

2 Formeln, die bestimmte Texte ausgeben

Betrifft: 2 Formeln, die bestimmte Texte ausgeben von: Christian
Geschrieben am: 03.09.2014 14:38:56

Hallo an alle,

ich suche 2 Formeln und würde mich freuen, wenn mir dabei jemand helfen könnte.

Beide Formeln sollen sich auf Tankstelle1!A1:A2000 beziehen.

Die eine Formel soll durch kopieren alle Zellinhalte ausgeben, die mit einer 5-stelligen Zahl und einem Leerzeichen beginnen (PLZ Ort)

Die andere Formel soll die dazugehörige Straße ausgeben, die jeweils in der Zelle obendrüber steht.

Wobei allerdings und das ist die Schwierigkeit in einem PLZ-Bereich mehrere Tankstellen sein können.

Hat da jemand eine Idee? ganz optimal wäre sogar, wenn nur der Ort ausgegeben würde, ohne die PLZ, aber wenn das zu kompliziert ist, nehme ich die Ausgabe auch mit PLZ.

Danke und schönen Gruß
Christian

  

Betrifft: Musterdatei von: Christian
Geschrieben am: 03.09.2014 14:47:35

https://www.herber.de/bbs/user/92459.xlsx

So sieht das Ganze aus, nur aufgrund der Größenbeschränkungen hier geht das Original noch weiter bis ca. Zeile 2000

An dem Tabellenaufbau lässt sich nichts ändern, da die Daten aus einer Datenverbindung aus dem Internet kommen.

Leider ist auch nicht möglich, zu sagen ab A17 ist jede 7. Zeile eine Straße und ab A18 jede 7. Zeile ein Ort, da es insgesamt 4 Seiten sind, die eingelesen werden und jede davon einen Anfang hat wie in A1:A12 und auch noch ein Ende mit Impressum usw.


  

Betrifft: AW: Musterdatei von: auch Christian
Geschrieben am: 03.09.2014 15:14:04

Hallo Christian,

ein Ansatz:

 ABCDEF
1Home   53332 BORNHEIMBONNER STR. 71
2Favoriten   53332 BornheimGüterbahnhofstrasse 3
3Statistiken   53332 BORNHEIMAM HELLENKREUZ 1
4Gutscheine   53332 BornheimAlexander-Bell-Str. 1
5    53332 Bornheim-WaldorfBlumenstraße 63
6Mein clever-tanken.de   53332 Bornheim-WiddigKölner Landstraße 67
7    53117 BONN - BUSCHDORFKÖLNSTR. 655
8Suche   53347 AlfterAlfterer Str. 165
9Geo   53119 BONNHOHE STR. 71
10    53119 BonnLandsberger Straße 2
11Aktuelle News   53117 BONNKOELNSTR. 455
12    53332 BORNHEIMBONN-BRUEHLER STR. 6
131.329   53859 Niederkassel-RheidtMarkstraße 109
14gemeldet Heute   50389 WesselingAHRSTR. 99
15vor 36 Min.   53119 BonnPotsdamer Platz 7
16TOTAL   53119 BONNBORNHEIMER STR. 145

Formeln der Tabelle
ZelleFormel
E1{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ISTZAHL(LINKS($A$1:$A$1000;5)*1)*LÄNGE($A$1:$A$1000)>7;ZEILE($A$1:$A$1000)); ZEILE(A1))); "")}
F1{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ISTZAHL(LINKS($A$1:$A$1000;5)*1)*LÄNGE($A$1:$A$1000)>7;ZEILE($A$1:$A$1000)); ZEILE(A1))-1); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

MfG Christian


  

Betrifft: AW: Musterdatei von: Christian
Geschrieben am: 03.09.2014 16:13:07

Hallo Christian,

das funktioniert soweit, danke.

Christian


 

Beiträge aus den Excel-Beispielen zum Thema "2 Formeln, die bestimmte Texte ausgeben"