Microsoft Excel

Herbers Excel/VBA-Archiv

wenn-und-Formel

Betrifft: wenn-und-Formel von: Inge
Geschrieben am: 11.09.2014 00:16:00

Hallo Profis,

ich brauche bitte mal Hilfe bei folgender Formel.

In A1 kann nur Apfel, Birne oder Banane stehen.
In B1 kann nur ein Wert von 0 bis 3 stehen. B1 kann auch leer sein.
In C1 soll eine Berechnung erfolgen, wenn der Wert in B1 größer 0 ist, und zwar bei Apfel Wert aus B1+2 und bei Birne Wert aus B1+1 (bei Banane keine Berechnung, nur Wert aus B1).

Folgende Formel würde ich verwenden, sie hat aber zuviele Argumente bzw. funktioniert nicht richtig.

=WENN(B1="";"leer";WENN(B1=0;B1);WENN(UND(A1="Apfel";B1>0);B1+2;WENN(UND(A1="Birne";B1>0);B1+1) ; wenn(und(A1="Banane";B1>0);B1)))

Ich hoffe, ich habe das verständlich beschrieben. Hat einer 'ne Idee, wie sich das lösen lässt? Schon mal vielen Dank im Voraus.

Gruß Inge

  

Betrifft: AW: wenn-und-Formel von: Gerold
Geschrieben am: 11.09.2014 00:34:44

Hallo Ingo

Probiers mal so.


=WENN(B1="";"leer";WENN(B1=0;B1;WENN(UND(A1="Apfel";B1>0);B1+2;WENN(UND(A1="Birne";B1>0);B1+1; _
WENN(UND(A1="Banane";B1>0);B1)))))

Gruß Gerold

Rückmeldung wäre nett.


  

Betrifft: AW: wenn-und-Formel von: Gerold
Geschrieben am: 11.09.2014 00:41:49

Hallo Ingo

Bitte ohne den Unterstrich



=WENN(B1="";"leer";WENN(B1=0;B1;WENN(UND(A1="Apfel";B1>0);B1+2;WENN(UND(A1="Birne";B1>0);B1+1; WENN(UND(A1="Banane";B1>0);B1)))))



Gruß Gerold

Rückmeldung wäre nett.


  

Betrifft: AW: wenn-und-Formel von: Rudi Maintaire
Geschrieben am: 11.09.2014 09:26:09

Hallo,
=WENN(B1="";"leer";WENN(B1=0;B1;B1-1+VERGLEICH(A1;{"Banane"."Birne"."Apfel"};0)))

Gruß
Rudi


  

Betrifft: genial ;-) kwT von: Matthias L
Geschrieben am: 11.09.2014 09:39:12




  

Betrifft: AW: wenn-und-Formel von: Inge
Geschrieben am: 11.09.2014 13:13:06

Hallo Gerold, hallo Rudi,

ganz herzlichen Dank für die schnelle Hilfe! Beide Formeln funktionieren perfekt!

Viele Grüße
Inge (jetzt ganz glücklich ;-))