Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung nach Wochentagen

Betrifft: Bedingte Formatierung nach Wochentagen von: Sven Kralemann
Geschrieben am: 12.11.2014 13:11:37

Hallo,
Ich möchte Zellen nach Wochentagen farblich formatieren.
Bei den Tagen Montag-Freitag und Sonntag (1-5 + 7) funktioniert das auch einwandfrei.



Mit dem Samstag haut das aber nicht hin...



Kann mir jemand helfen?

  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: Hajo_Zi
Geschrieben am: 12.11.2014 13:13:03

Ein Bild in Excel geöffnet sieht anders aus als das Bild.
Ich habe kein Tool um ein Bild in Excel zu importieren.

GrußformelHomepage


  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: SF
Geschrieben am: 12.11.2014 13:13:51

Hola,

kannst du das anhand einer Beispieldatei deutlich machen?

Gruß,
steve1da


  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: Sven Kralemann
Geschrieben am: 12.11.2014 13:29:17

Hier mal ein Test

https://www.herber.de/bbs/user/93706.xlsx


  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: SF
Geschrieben am: 12.11.2014 13:35:51

Hola,

hat das einen bestimmten Grund dass die Daten abwechselnd in Spalte A und B stehen?

Bei einer leeren Zelle in Spalte A ist die Bedingung immer WAHR - prüfen kannst du das indem du in Q1 folgendes schreibst:

=WOCHENTAG($A1;2)=6
Die bed. Formatierung arbeitet richtig, Grund sind wie gesagt die leeren Zellen, da du dich immer nur auf Spalte A beziehst.

Gruß,
steve1da


  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: Sven Kralemann
Geschrieben am: 12.11.2014 13:58:08

@steve1da
ich erstelle einen Schichtplan bei dem sich Schichten überschneiden - darum 2 Spalten pro Tag :-)


  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: Hajo_Zi
Geschrieben am: 12.11.2014 13:36:23

Du Wolltest doch Sonnabend markiert haben, Ich habe grün gelöscht und neu erstellt.

Tabelle1

 ABCDEFGHIJ
1Sa         
2 Sa        
3So         
4 So        
5Mo         
6 Mo        
7Di         
8 Di        
9Mi         
10 Mi        
11Do         
12 Do        
13Fr         
14 Fr        
15Sa         
16 Sa        
17So         
18 So        
19Mo         
20 Mo        
21Di         
22 Di        
23Mi         
24 Mi        
25Do         
26 Do        
27Fr         
28 Fr        
29Sa         
30 Sa        
31So         
32 So        
Bedingte Formatierung Fülleffekte, Symbole, Farbskalen
werden in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel Bereich N/A
A3,B4,A5,B6,A7,B8,A9,B10,A11,B12,A13,B14,A15,B16,A17,B18,A19,B20,A21,B22,A23,B24,A25,B26,A27,B28,A29,B30,A31,B32=A1+1  

Bedingte Formatierung Haupttabelle 1  
Zelle   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$C:$J01.Bed.: Formel ist =UND($A1<>"";WOCHENTAG($A1;2)=6)  5296274         2C:J
$C$1:$F$3202.Bed.: Formel ist =WOCHENTAG($B1;2)=4  192         2C1:F32

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.20 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: Bernd
Geschrieben am: 12.11.2014 13:36:19

Hi,

probier mal so (wäre für Samstag und Sonntag:

~=WENN(A$1=7;1;0)~ ~=WENN(A$1=1;1;0~)

lg Bernd


  

Betrifft: AW: Bedingte Formatierung nach Wochentagen von: Sven Kralemann
Geschrieben am: 12.11.2014 13:55:24

Vielen Dank Hajo_Zi

so funktioniert´s - wenngleich ich nicht verstehe warum es mit der Formel die ich für die anderen Tage verwende nicht geht...

Gruß Sven


 

Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung nach Wochentagen"