Microsoft Excel

Herbers Excel/VBA-Archiv

Array Formel mit zwei möglichen Bedingungen

Betrifft: Array Formel mit zwei möglichen Bedingungen von: Paul
Geschrieben am: 12.11.2014 12:37:46

Hallo,

ich hab mal eine array Frage, ich komme einfach nicht darauf.

In Spalte A stehen diverse Kundennummern. In Spalte B KANN eine Zahl stehen. In Spalte C möchte ich nun den Wert 1 ausgeben, wenn zu einer Kundennummer mindestens 1 mal in Spalte B eine Zahl steht.

Spalte A
123
456
123
123

Spalte B

2012
2013

Spalte C
1
0
1
1

Sorry dass ich die Spalten nicht nebeneinander gestellt bekomme.

Viele Grüße

Paul

P.S: Es muss nicht zwingend über eine Matrixformel sein.

  

Betrifft: AW: Array Formel mit zwei möglichen Bedingungen von: SF
Geschrieben am: 12.11.2014 12:42:10

Hola,

so?

=WENN(ZÄHLENWENNS($A$1:$A$4;A1;$B$1:$B$4;"<>");1;0)
Gruß,
steve1da


  

Betrifft: AW: Array Formel mit zwei möglichen Bedingungen von: Hajo_Zi
Geschrieben am: 12.11.2014 12:43:47

Hallo Paul,


Tabelle5

 ABCD
1123 11
2456 00
3123201211
4123201311
5  Vorgabe 

verwendete Formeln
Zelle Formel Bereich N/A
D1: D4=N(SUMMENPRODUKT((A1:A4=A1)*B1:B4)>0)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.20 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Array Formel mit zwei möglichen Bedingungen von: Hajo_Zi
Geschrieben am: 12.11.2014 12:47:18

esmuss absolut sein.

Tabelle5

 ABCD
1123 11
2456 00
3123201211
4123201311
5  Vorgabe 

verwendete Formeln
Zelle Formel Bereich N/A
D1: D4=N(SUMMENPRODUKT(($A$1:$A$4=A1)*$B$1:$B$4)>0)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.20 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Array Formel mit zwei möglichen Bedingungen von: Paul
Geschrieben am: 12.11.2014 13:49:43

Moin,

ich danke euch recht herzlich. Ihr habt mir sehr geholfen =)

Viele Grüße

Paul


 

Beiträge aus den Excel-Beispielen zum Thema "Array Formel mit zwei möglichen Bedingungen"