Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
964to968
964to968
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Datumsfilter auf Zeilen setzen?
06.04.2008 12:37:00
Mathias
Hallo Excelfreunde,
ich bin mal wieder auf eure Hilfe angewiesen :)
Folgende kleine Aufgabe gilt es zu lösen...
1) in der Spalte G im Bereich G4:G10000 stehen Datumswerte mit Uhrzeit, ein Beispiel für Zelle G4
dieses wird über diese Formel ermittelt =WENN(H4="";"";WENN(G4="";JETZT();G4))
2) in Zelle i2 schreibe ich eine Zahl, z.B. 20 od. 42 etc.
2a) nun soll immer vom heutigen Datum die Anzahl an Tagen abgezogen werden, welche in Zelle i2 steht,
Als Ergebnis erhalten wir ein Datum, welches z.B. 20 od. 42 Tage in der Vergangenheit liegt
1. Aufgabe: Erreicht werden soll, dass Bereich G4:G10000 überprüft wird und alle Zeilen, bei denen das Datum mindestens so weit in der Vergangenheit liegt, wie in Zelle i2 geschrieben gefiltert werden.
Filterbereich ab Zeile 4 bis 10000
Als kleine Besonderheit gibt es zu beachten, dass in Zeile 3 ein Atutofilter aktiv sein kann, dieser Filter müsste dann vorrübergehend ausgeschaltet werden.

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Datumsfilter auf Zeilen setzen?
06.04.2008 16:27:00
Ramses
Hallo
Automatisiert mit zurückliegendem Datumszeitraum geht nur via VBA
Das ist deine Tabelle
Tabelle1

 ABCDE
1   Heute06.04.2008
2   Minus40
3DatumWert   
1104.03.2008A   
1213.03.2008A   
1322.03.2008A   
14     


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
und nun kannst du diesen Code einem Commandbutton zuweisen.
Bezüge entsprechend ändern
Option Explicit

Sub Makro1()
    'by Ramses
    ActiveSheet.AutoFilterMode = False
    Range("A3").AutoFilter Field:=1, Criteria1:="<=" & CDbl(Range("E1")), Operator:=xlAnd, Criteria2:=">=" & CDbl(Now - Range("E2"))
End Sub

Gruss Rainer
Anzeige

304 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Links zu Excel-Dialogen

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige