Microsoft Excel

Herbers Excel/VBA-Archiv

summe wenn Zellinhalt = Zahl

Betrifft: summe wenn Zellinhalt = Zahl von: baronf
Geschrieben am: 14.08.2008 09:01:19

Hallo Leute,
ich habe eine Frage:
ich habe in der Spalte A Zellen, die ich addueren möchte.

jetzt kann es vorkommen, dass nicht in jeder Zelle eine Zahl steht, da der Zellinhalt über eine Formel generiert wird (Sverweis).

A1= 10.000
A2=12.000
A3=#NV
A4=2300
=summe(A1;A2;A3;A4)
usw.
was für eine Formel kann ich nehmen, dass A3 in diesem Fall nicht berücksichtigt wird? A3 kann aber je nach Eintrag im Bezugsblatt auch eine Zahl als Inhalt bekommen!!

Danke
Frederike

  

Betrifft: {=SUMME(WENN(ISTZAHL(A1:A99);A1:A99))} von: WF
Geschrieben am: 14.08.2008 09:08:03

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

Salut WF


  

Betrifft: AW: summe wenn Zellinhalt = Zahl von: baronf
Geschrieben am: 14.08.2008 09:50:59

Klaapt nicht! geht das auch anders?


  

Betrifft: AW: summe wenn Zellinhalt = Zahl von: Erich G.
Geschrieben am: 14.08.2008 09:57:39

Hi,
was meinst nu mit "Klaapt nicht!"??? Was kommt bei dir raus?

Es geht. Wichtig ist der Hinweis zur Matrixformel:

 ABC
1100002430024300
212000  
3#NV  
42300  

Formeln der Tabelle
ZelleFormel
B1{=SUMME(WENN(ISTZAHL(A1:A4); A1:A4))}
C1{=SUMME(WENN(ISTZAHL(A1:A99); A1:A99))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: nee - anders geht's nicht. von: WF
Geschrieben am: 14.08.2008 09:57:51

.


  

Betrifft: SUMMEWENN() von: FP
Geschrieben am: 14.08.2008 19:26:32

Hallo Frederike,

siehe Beispiel:

Tabelle1
 ABC
110000  
212000  
3#NV  
42300 24300
Formeln der Tabelle
C4 : =SUMMEWENN(A:A;">1e-307";A:A)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


  

Betrifft: sieht ja spektakulär aus von: WF
Geschrieben am: 14.08.2008 19:50:40

Hi Franz,

aber egal, was in Spalte A steht: es kommt immer 10 raus.

??
WF


  

Betrifft: AW: sieht nicht nur spektakulär aus von: Erich G.
Geschrieben am: 14.08.2008 19:59:54

Hi Walter,
wo ist da der Haken?

 ABC
11000  
25000  
3#NV 16000
410000 16000

Formeln der Tabelle
ZelleFormel
C3{=SUMME(WENN(ISTZAHL(A1:A4); A1:A4))}
C4=SUMMEWENN(A:A;">1e-307";A:A)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: reine Blödheit - Danke von: WF
Geschrieben am: 14.08.2008 20:07:33

meine Zahlen standen in Spalte F

Die Formel ist Klasse !

WF


  

Betrifft: und man kann sie in diesem Fall von: FP
Geschrieben am: 14.08.2008 20:14:43

Hallo Walter,

sogar noch kürzen, denn die Angabe des zweiten Bereichs darf man weglassen, wenn der Bedingungsbereich mit dem zu summierenden Bereich ident ist.

=SUMMEWENN(A:A;">1e-307")


Servus aus dem Salzkammergut
Franz


  

Betrifft: d.h. damit auch negative Zahlen ... von: FP
Geschrieben am: 14.08.2008 20:20:40

Hallo Walter,

summiert werden:

=SUMMEWENN(A:A;">-1e307")

Servus aus dem Salzkammergut
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "summe wenn Zellinhalt = Zahl"