Automatische Auflistung Systemdatum



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Automatische Auflistung Systemdatum
von: sergen
Geschrieben am: 22.05.2002 - 19:44:20

Hallo Leute,

in Excel möchte ich in Spalte A das Systemdatum automatisch eingetragen haben und zwar solange in der Nebenspalte bzw. Nebenzelle ein Wert steht.

Wer kann mir da helfen?
Mit tausend Dank und fG, Sergen


nach oben   nach unten

Re: Automatische Auflistung Systemdatum
von: Klaus Schubert
Geschrieben am: 22.05.2002 - 21:34:52

Hallo Sergen,

wenn du in z.B. in Zelle A1 folgende Formel einsetzt:
=WENN(B1<>"";HEUTE();" ")

dann wird dir immer das Systemdatum angezeigt ,wenn in Zelle B1 ein Wert eingetragen ist.Allerdings ändert sich dieses dann am nächsten Tag mit.

Willst du aber eine aktuelle Kopie vom Datum haben, wenn ein Eintrag erfolgt, habe ich hier eine benutzerdefinierte Funktion, die dieses Problem lösen sollte:

Mit Alt + F11 in die VBA - Umgebung wechseln und dann folgenden Code in ein normales Modul reinkopieren:


Function SystemdatumKopieren(Zelle As Range)
If Zelle <> "" Then
SystemdatumKopieren = Format(Date, "dd mm yyyy")
Else
SystemdatumKopieren = ""
End If
End Function

Jetzt kannst du z.B. in Zelle A1 die neue Funktion nutzen, z.B. so:

=SystemdatumKopieren(B1)

Jetzt wird das Datum in der Zelle nur noch aktualisiert, wenn du in Zelle B1 einen Wert eingibst bzw. aktualisierst.

Diese Funktion einfach in der Spalte A runterkopieren, wo sie benötigt wird.

Gruß Klaus


nach oben   nach unten

Re: Automatische Auflistung Systemdatum
von: regina
Geschrieben am: 22.05.2002 - 21:41:59

Hallo Sergen
Sub heute()
Dim c As Date
Dim i As Range
ende = Cells(65536, 2).End(xlUp).Row 'von letzter Zeile aufwärts

For c = 1 To ende

If Not IsEmpty(Cells(c, 2)) Then
Cells(c, 1) = Date

End If
Next

End Sub


versuchs mal mit
Gruß Regina


nach oben   nach unten

Re: Automatische Auflistung Systemdatum
von: sergen
Geschrieben am: 23.05.2002 - 11:33:42

Vielen Dank Regina,

ich werde es versuchen. Und wenn es klappt, dann bekommst Du die Bestätigung.

Grüsse aus Köln, sergen


nach oben   nach unten

Re: Automatische Auflistung Systemdatum
von: sergen
Geschrieben am: 23.05.2002 - 11:36:18

Hallo Klaus,

vielen Danke für Deine Unterstützung.

Grüsse aus Köln, sergen


nach oben   nach unten

Re: Automatische Auflistung Systemdatum (Regina)
von: sergen
Geschrieben am: 23.05.2002 - 16:36:31

Hallo Regina,

Dein Programm läuft sehr gut, allerdings aktualisiert es das Systemdatum in den zuvor eingefügten Einträgen. Ginge das so, dass das Datum ab der Einfügung abwärts eingetragen wird?

Genauso oder ähnlich müsste es mit einer Abfrage von Zellen laufen, z.B:
Ist Zelle d2>=0 und Zelle f2>0, dann 1;
Ist Zelle d2>=0 und Zelle f2<=0, dann 2;
Ist Zelle d2<0 und Zelle f2>=0, dann 3;
Ist Zelle d2<0 und Zelle f2<0, dann 4;

Vielen, vielen Dank für Deine Hilfe
und viele Grüsse aus Köln, sergen

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Automatische Auflistung Systemdatum"