Microsoft Excel

Herbers Excel/VBA-Archiv

Formel als Wert einfügen | Herbers Excel-Forum


Betrifft: Formel als Wert einfügen von: Heinz H
Geschrieben am: 25.01.2012 18:04:27

Hallo Leute

Ich habe in Spalte T2:T5000 untere Formel.

  • =WENN($C119="";0;WENN(ISTFEHLER(SVERWEIS($C119;Artikeln!$A$2:$F$5000;6;FALSCH));"";SVERWEIS($C119;Artikeln!$A$2:$F$5000;6;FALSCH)))


  • Nun möchte ich gerne, in Spalte G, den Wert von T eingefügt haben.
    In diesen Beispiel von T119 in G119

  • Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
    :=False, Transpose:=False


  • Könnte mir dazu bitte jemand helfen ?

    Gruß
    Heinz

      

    Betrifft: AW: Formel als Wert einfügen von: Hajo_Zi
    Geschrieben am: 25.01.2012 18:08:58

    Hallo Heinz,

    schreibe f+ür Selection Tange("G1)
    den Teil
    , Operation:=xlNone, SkipBlanks _
    :=False, Transpose:=False
    kannst Du löschen.

    GrußformelHomepage


      

    Betrifft: AW: Formel als Wert einfügen von: Heinz H
    Geschrieben am: 25.01.2012 18:24:19

    Hallo Hajo
    So funkt.es leider nicht.

  • Selection.Tange("G1").PasteSpecial Paste:=xlPasteValues


  • Gruß
    Heinz


      

    Betrifft: wer ist Tange ,versuch mal Range ;o) kwT von: Matthias L
    Geschrieben am: 25.01.2012 18:30:00




      

    Betrifft: AW: Formel als Wert einfügen von: Hajo_Zi
    Geschrieben am: 25.01.2012 18:31:38

    Hallo Heinz,

    ich habe mich verschrieben nicht Tange sondern Range und mache das was ich geschrieben habe ersetzen.

    GrußformelHomepage


      

    Betrifft: AW: Formel als Wert einfügen von: Heinz H
    Geschrieben am: 25.01.2012 20:25:52

    Hallo Hajo

    sondern Range und mache das was ich geschrieben habe ersetzen.
    Danke,jetzt funktioniert auch Deine Version.

    Recht herzlichen Dank
    Gruß
    Heinz


      

    Betrifft: .value=.value mit Offset() ... von: Matthias L
    Geschrieben am: 25.01.2012 18:28:43

    Hallo Heinz

    Option Explicit
    Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("C2:C5000")) Is Nothing Then
    Target.Offset(, 4).Value = Target.Offset(, 17).Value
    End If
    End Sub
    Bei Änderung eines Wertes in Spalte(C) wird In Spalte(T) die Formel neu berechnet.
    In Spalte(G) schreibst Du nun den Wert der Formel aus Spalte(T)

    Target.Offset(, 4) ist die 4. Spalte rechts neben Spalte(C), also Spalte(G)
    Target.Offset(, 17) ist die 17. Spalte rechts neben Spalte(C), also Spalte(T).. die mit der Formel

    Gruß Matthias


      

    Betrifft: AW: .value=.value mit Offset() ... von: Heinz H
    Geschrieben am: 25.01.2012 18:31:03

    Hallo Matthias

    Punktgenau !!
    Recht herzlichen Dank.

    Gruß
    Heinz


    Beiträge aus den Excel-Beispielen zum Thema "Formel als Wert einfügen"