Microsoft Excel

Herbers Excel/VBA-Archiv

automatische Erkennung und Eingabe



Excel-Version: 9.0 (Office 2000)

Betrifft: automatische Erkennung und Eingabe
von: Gerd
Geschrieben am: 29.05.2002 - 17:05:55

Servus alle miteinander,

ich bin auf der Suche nach einem MAkro, das mir bei der Eingabe eines Textes in eine Zelle in der direkt nebenliegenden Zelle das heutige Datum dazusetzt. Könnt Ihr mir Helfen?

Vielen Dank im voraus!

Ciao

Gerd


  

Kleine Datums-Funktion
von: Volker Croll
Geschrieben am: 29.05.2002 - 18:51:53

Hallo Gerd,

mal einen Schnellschuss - in ein Modul folgendes:


Function Datum_heute()
    Datum_heute = Date
End Function

Wenn Deine Texte z.B. in A1 eingegeben werden, dann in B1 die Formel:

=WENN(A1<>"";Datum_heute();"")

Das Datum, welches jetzt hier automatisch eingetragen wird, bleibt unveraendert, solange der Text in A1 nicht veraendert wird. Also auch wenn die Tabelle morgen, uebermorgen, wann auch immer wieder geoeffnet wird.

Kommst Du damit weiter?

Gruss Volker

 

Beiträge aus den Excel-Beispielen zum Thema "automatische Erkennung und Eingabe"