Ich suche Hilfe bei Matrix mit Sverweis

Bild

Betrifft: Ich suche Hilfe bei Matrix mit Sverweis
von: Uwe
Geschrieben am: 28.07.2015 16:05:46

Guten Tag Zusammen,
ich habe noch nie in ein Excel Forum geschreiben, sondern immer nur Hilfe gefunden. Leider ist das diesmal nicht so, ich weiß nichtmal nach welchen Schlagworten suchen soll. Vielleich kann mir jemand helfen.
Ich erhalte monatlich über eine SAP Schnittstelle Telefonkosten von Nebenstellen und Mobilfunk(Spalte A+B). Die Aufteilung der Werte innerhalb der Zelle ist einheitlich. Leider kommen Mobilfunk und Nebenstelle untereinander in der dargestellten Anordnung, mit Werten die ich nicht benötige.
In einem weiteren Blatt habe ich die Rufnummern und Namen. (Spalte E+F)
https://www.herber.de/bbs/user/99123.xlsx
Nun meine Frage:
Kann man mit einer Formel den Namen aus Spalte "F" in die Spalte "C" einfügen?
Der Suchbezug ist in Spalte "A" der Matrixbereich ist Spalte "E"
Ich hoffe es kann mir jemand helfen. Danke, Gruß Uwe

Bild

Betrifft: in C2 gibst Du ein:
von: WF
Geschrieben am: 28.07.2015 16:18:47
=INDEX(F:F;VERGLEICH("*"&E2&"*";A:A;0))
Da die Rufnummer immer Teil der Bezeichnung in derselben Zeile ist, reicht ja =F2 ?
WF

Bild

Betrifft: AW: in C2 gibst Du ein:
von: Uwe
Geschrieben am: 28.07.2015 17:26:49
Hallo WF,
vielen Dank für Deine schnelle Antwort. Die Zeile ändert sich leider. Der Matrixbereich ist zudem auf einem anderen Tabellenblatt. Ich habe die Tabelle nochmal überareitet und den Matrixbereich auf das Blatt "Rufnummern DB" übertragen.
Ziel ist auf dem Blatt "Telefon Kosten" in Spalte "C" den Namen des Rufnummernutzer vom Blatt "Rufnummern DB" aus der Spalte "B" zu übertragen.
Vielleicht kannst Du das nochmals ansehen? Sorry für die Verwirrung.
Gruß Uwe
https://www.herber.de/bbs/user/99127.xlsx

Bild

Betrifft: jetzt nur mit Krücke
von: WF
Geschrieben am: 28.07.2015 19:08:29
Hi,
in der Tabelle Rufnummern DB gibst Du in D2 ein:
=WENNFEHLER(VERGLEICH("*"&A2&"*";'Telefon Kosten'!A:A;0);"")
bis D9 runterkopieren
Das Ergebnis dann in C2 der Tabelle Telefon Kosten:
=INDEX('Rufnummern DB'!B:B;VERGLEICH(KKLEINSTE('Rufnummern DB'!D:D;ZEILE(A1));'Rufnummern DB'!D:D;0))
runterkopieren
WF

Bild

Betrifft: AW: jetzt nur mit Krücke
von: Uwe
Geschrieben am: 29.07.2015 10:19:50
Hallo WF,
irgendetwas funktioniert nicht, auf dem Blatt "Rufnummern DB" bekomme ich Zahlen, auf dem Blatt "Telefon Kosten" der Fehler > #ZAHL <
Ich habe die Beispieltabelle mit den Formeln nochmals hochgeladen, was mache ich falsch?
Die Beispieltabelle ist nur ein Auszug, später wird es auf beiden Blättern deutlich mehr Zeilen geben. Geht die Formel dann trotzdem?
https://www.herber.de/bbs/user/99141.xlsx

Bild

Betrifft: na, das müsstest Du selber merken
von: WF
Geschrieben am: 29.07.2015 10:49:49
in der Formel auf Telefon Kosten steht:
=INDEX('Rufnummern DB'!B:B;VERGLEICH(KKLEINSTE('Rufnummern DB'!D:D;ZEILE(A1));'Rufnummern DB'!D:D;0))
also 2 mal D:D - das muss C:C sein (die Hilfsspalte in Rufnummern DB hast Du in C platziert)
WF

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Ich suche Hilfe bei Matrix mit Sverweis"