Anzeige
Archiv - Navigation
460to464
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
460to464
460to464
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Preise in Bestellformular einlesen lassen

Preise in Bestellformular einlesen lassen
25.07.2004 14:04:36
Jesko
Hallo an alle, die diesen Sonntag Excel verschrieben haben!
Mich beschäftigt folgende Fragestellung:
Ich habe ein Bestellformular, in das ich Preise aus einer Preistabelle einlesen lassen möchte. Diese Preistabelle hat etwa folgendes Aussehen:
Type 100-199 Stück 200-299 Stück 300-399 Stück etc.
A 1,00 Euro 2,00 Euro 3,00 Euro
B 2,00 Euro 3,00 Euro 4,00 Euro
C 7,00 Euro 8,,50 Euro 9,00 Euro
Die entscheidende Zeile im Bestellformular verfügt über die Zellen Type, Stückzahl und Preis. Die Werte in den Zellen Type und Stückzahl werden über ein Popup-Menü ausgewählt (Daten – Gültigkeit – Einstellungen – Liste). Wie lässt sich nun der zu dieser Type und Stückzahl gehörige Preis automatisch am einfachsten einlesen?
Interessant wird die Sache dadurch, dass ein Preis nicht für eine bestimmte Stückzahl, sondern für eine Mengenspanne gilt.
Euch schon einmal vielen Dank!
Jesko

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Preise in Bestellformular einlesen lassen
Ramses
Hallo
Der Bereich in D2:D7 ist mit dem Benutzerdefiniertem zahlenformat
"ab "* 0.00
belegt.
Den Rest kannst du aus der Hilfe unter SVERWEIS ersehen
Tabelle1
 ABCDEF
1MengePreis Preise  
21 SFr.    1.00  ab                        0.00 SFr.                 1.00  
3211 SFr.    0.90  ab                       10.00 SFr.                 0.95  
4767 SFr.    0.80  ab                     100.00 SFr.                 0.90  
5   ab                     300.00 SFr.                 0.85  
6   ab                     500.00 SFr.                 0.80  
7   ab                   1000.00 SFr.                 0.75  
8      
9      
Formeln der Tabelle
B2 : =SVERWEIS(A2;$D$2:$E$7;2;1)
B3 : =SVERWEIS(A3;$D$2:$E$7;2;1)
B4 : =SVERWEIS(A4;$D$2:$E$7;2;1)
 

Gruss Rainer
Anzeige
AW: Preise in Bestellformular einlesen lassen
25.07.2004 15:54:23
Jesko
Hallo Rainer,
danke für Deine Antwort. Deinen Lösungsvorschlag finde ich sehr gut, nur müsste die Type auch mit berücksichtigt werden, da die Staffelpreise je Type wieder unterschiedlich sind. Das einizge, was konstant bleibt, sind die Mengenspannen.
Jesko
AW: Preise in Bestellformular einlesen lassen
Ramses
Hallo
Die Bereiche F2:G7 und F11:G16 wurden genauso benannt wie der Type heisst, also
F2:G7 = Apfel
F11:G16 = Birne
sonst geht es nicht
KLSDFLKJ
 ABCDEFGH
1MengeArtikelPreis  Preis Apfel  
278Apfel0.95  01 
3110Birne3.5  100.95 
4     1000.9 
5     3000.85 
6     5000.8 
7     10000.75 
8        
9        
10     Preis Birne  
11     04 
12     103.9 
13     1003.5 
14     3003.2 
15     5002.9 
16     10002.5 
17        
Formeln der Tabelle
C2 : =SVERWEIS(A2;INDIREKT(B2);2;1)
C3 : =SVERWEIS(A3;INDIREKT(B3);2;1)
 

Gruss Rainer
Anzeige
AW: Preise in Bestellformular einlesen lassen
Jesko
Hallo,
gibt es nicht doch eine Variante, bei der ich die Preistabelle, aus der hinterher die Werte ausgelesen werden sollen, wie oben erwähnt aufbauen kann?
1. Spalte: Typen
2. Preisstaffel: 100-199 Stück
3. Preisstaffel: 200-299 Stück
etc.
Jesko
Noch offen...
Ramses
Hallo
Klar, es gibt tausende Möglichkeiten.
Ich habe dir eine Variante angeboten die dein Problem löst.
Du willst/kannst diese nicht verwenden.
OK
... aber erwarte nicht von mir, dass ich nun alle Möglichkeiten hier aufzeige bis dir etwas genehm ist.
Gruss Rainer
Offen vergessen. o.T.
Ramses
...
AW: Noch offen...
Jesko
Hallo Rainer,
niemand hat behauptet, dass ich Deinen Lösungsvorschlag nicht verwenden will / kann!
Vielleicht gibt es aber unter Deinen tausend Möglichkeiten eine, die es mir erlaubt, den Preistabellenaufbau - wie von mir beschrieben - beizubehalten.
Würde mich freue, noch einmal von Dir zu hören.
Gruss,
Jesko
Anzeige
AW: Noch offen...
Ramses
Hallo
Hiewr ein Beispiel mit deiner Preistabelle
Tabelle1
 ABCDEF
1Type  ab           0  ab       100  ab       500  ab     1000 
2a100908070 
3b50494847 
4c10864 
5      
6      
7      
8TypMengeE-PreisTotal  
9a5100500  
10b7004833600  
11c1018808  
12      
13      
14      
Formeln der Tabelle
C9 : =SVERWEIS(A9;$A$2:$E$4;VERGLEICH(B9;$B$1:$E$1;1)+1;0)
D9 : =C9*B9
C10 : =SVERWEIS(A10;$A$2:$E$4;VERGLEICH(B10;$B$1:$E$1;1)+1;0)
D10 : =C10*B10
C11 : =SVERWEIS(A11;$A$2:$E$4;VERGLEICH(B11;$B$1:$E$1;1)+1;0)
D11 : =C11*B11
 

Es MUSS einen Nullwert geben.
Zeile 1 enthalt das ZAHLENFORMAT !!!! " ab"* 0"
Gruss Rainer
Anzeige

300 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige