Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn Formel | Herbers Excel-Forum


Betrifft: Zählenwenn Formel von: Dani
Geschrieben am: 02.01.2012 22:31:21

Hallo zusammen

In einem Thread von 2003 habe ich folgendes gefunden:
Thread

=ZÄHLENWENN(A:A;"Hallo")+ZÄHLENWENN(Tabelle2!A:A;"Hallo")+ZÄHLENWENN(Tabelle3!A:A;"Hallo") 
Ich muss in Tabellenblättern über das ganze Jahr suchen, das heisst, jedes Tabellenblatt hat den Monatsnamen. Nun habe ich die Tabellenname in der obigen Formel in die Monate geändert.
=ZÄHLENWENN(Erfassen!B:B;B2)+ZÄHLENWENN(Dezember!B:B;B2)+ZÄHLENWENN(Januar!B:B;B2)  etc.
Doch da nicht immer alle Tabellenblätter vorhanden sind (diese kommen immer erst am 27. des Monats) bekomme ich den Fehler #Wert zurück.
Wie muss ich die Formel anpassen, dass sie auch unter dem Jahr klappt, also nicht erst ende des Jahres?

Danke schon mal für eure Hilfe

Gruess Dani

  

Betrifft: AW: Zählenwenn Formel von: Josef Ehrensberger
Geschrieben am: 02.01.2012 23:12:08


Hallo Dani,

eine Möglichkeit.

http://www.excelformeln.de/formeln.html?welcher=234

Tabelle6

 ABCDEFGHIJ
1        Erfassung<-- hier die zu erfassenden Tabellen angeben
2 5      Januar 
3          
4 3        
5          

Formeln der Tabelle
ZelleFormel
B4{=SUMME(ZÄHLENWENN(INDIREKT("'"&_Tab&"'!B:B"); B2))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen
Namen in Formeln
ZelleNameBezieht sich auf
B4_Tab=Tabelle6!$I$1:INDEX(Tabelle6!$I:$I;ANZAHL2(Tabelle6!$I:$I))
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Zählenwenn Formel von: Dani
Geschrieben am: 03.01.2012 12:31:25

Hallo Sepp

Super genau das was ich brauchte. Danke

Gruess Dani


Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn Formel"