Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn wert einer Spalte >=, dann Wert eines Feldes

Betrifft: Wenn wert einer Spalte >=, dann Wert eines Feldes von: Stephan
Geschrieben am: 10.09.2004 10:36:27

Hallo alle zusammen,

habe da so ein kleines Problem. Habe 2 Spalten. Eine Spalte mit ansteigenden Zahlen (spalte a), die andere mit Datum (spalte B).
Möchte nun in einem anderen Feld anzeigen, wenn in der Spalte A ein bestimmter Maximalwert erreicht ist, soll er mir das Datum, das in der gleichen Zeile auf gleicher Höhe steht ausgeben.

Kann mir da irgendjemand helfen, wäre super nett.

Danke im vorraus.
Lg
Stephan

  


Betrifft: AW: Wenn wert einer Spalte >=, dann Wert eines Feldes von: Andy
Geschrieben am: 10.09.2004 10:48:48

Hallo.
versuche es mal mit der formel. wenn sie funktioniert einfach nach unten kopieren.
Wert durch die zahl ersetzen..

=wenn(A1>=wert;B1;"Maximalwert wurde nicht erreicht")

Gruß
Andy


  


Betrifft: AW: Wenn wert einer Spalte >=, dann Wert eines Feldes von: HermannZ
Geschrieben am: 10.09.2004 11:04:10

Hallo Stephan,

vieleicht so??

DatumZeitMuster
 ABCD
1335DatumWert  
133601.07.20041009.07.2004 
133702.07.20045  
133803.07.20047  
133907.07.200420  
134008.07.200415 gesuchtes Datum zum Wert
134109.07.20043507.07.200420
1342    
1343    
Formeln der Tabelle
C1336 : =INDEX(A1336:A1343;VERGLEICH(MAX(B1336:B1343);B1336:B1343;0);1)
C1341 : =WENN(D1341="";"";INDEX(A1336:A1343;VERGLEICH(D1341;B1336:B1343;0);1))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


  


Betrifft: AW: Wenn wert einer Spalte >=, dann Wert eines Feldes von: Stephan
Geschrieben am: 10.09.2004 11:06:43

Hi,

danke für die superschnelle Antworten, ich probiers mal und meld mich dann noch mal.

Danke


  


Betrifft: AW: Wenn wert einer Spalte >=, dann Wert eines Feldes von: Stephan
Geschrieben am: 10.09.2004 11:26:56

Hi nochmal,

wär ja schon echt super, gibt aber noch ein kleines Problem:
Das Problem ist, dass die Werte in der B Tabelle nicht gleich dem gesuchten Wert sind, sie steigen stetig an und irgendwann wir der gesuchte Wert überschritten. Genau dann bruach ich das Datum, steigt auch stetig an, zu dem Zeitpunkt wo es überschritten wird.

Zur Veranschaulichung:
A B
20.10.2003 500
20.12.2003 500+300=800
20.02.2004 500+300+500=1300
20.04.2004 500+300+500+400=1700
Gesuchter Wert, beziehungsweise wenn der Wert 1000 überschreitet, hätte ich gerne, das er mir das Datum 20.02.2004 ausgibt

Danke nochmals im vorraus

Lg
Stephan


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn wert einer Spalte >=, dann Wert eines Feldes"