Microsoft Excel

Herbers Excel/VBA-Archiv

Martixformeln, SUMMEWENN und mehrere Spalten?



Excel-Version: Alle Versionen

Betrifft: Martixformeln, SUMMEWENN und mehrere Spalten?
von: Martin
Geschrieben am: 07.06.2002 - 13:02:54

Hallo,

Spalte A enthält Namen,
Spalte B dito,
Spalte C einen Wert
Spalte D dito

Bsp
A _____ B ______C_D
Team1 _ Team2 _ 1_2
Team2 _ Team1 _ 1_0
Team2 _ Team1 _ 3_0
Team1 _ Team2 _ 0_0

unschwer zu erkennen, dass es sich um eine Fussballtabelle handelt ;-)

Ich möchte in Abhängigkeit vom Team die erzielten Tore ermitteln.
Dazu dachte ich die Spalte A (oder genauer der Bereich, sagen wir A1:A3) und B nach Team"x" durchsuchen zu lassen und entsprechend die Werte der Spalte C & D addieren zu lassen.

Das Ergebnis von oben sollte mithin lauten
Team1 > 1
Team1 > 6

Habe es mit allen möglichen Varianten versucht, bekomme es aber nicht hin, dass xl korrekt rechnet oder die Formel funktioniert.
Geht so etwas nicht oder wie lautet die Formel??

Gruss,
Martin



  

Re: Martixformeln, SUMMEWENN und mehrere Spalten?
von: Coach
Geschrieben am: 07.06.2002 - 13:06:59

Hallo Martin,

=SUMMEWENN(A2:A5;"Team1";C2:C5)+SUMMEWENN(B2:B5;"Team1";D2:D5)

Gruß Coach

  

schnell, effizient, ..
von: Martin
Geschrieben am: 07.06.2002 - 13:15:25

super!

Vielen Dank.
Martin


  

=SUMMENPRODUKT((A2:B20="team1")*C2:D20)
von: WF
Geschrieben am: 07.06.2002 - 13:48:09

http://www.excelformeln.de/
die ultimative Formelseite
  

wird ja immer besser ..
von: Martin
Geschrieben am: 07.06.2002 - 16:09:16

wirklich toll. Ich verstehe nur nicht, warum ich mich mit Matrizen so schwer tue. Das sieht alles so einfach und logisch aus!?

Weitergehende Frage:
In zwei weiteren Spalten liste ich die Punkte auf (0, 1 oder3).
Jetzt sollen die 0-Punkte, 1-Punkt und 3-Punkte (in jeweils unterschiedlichen Zellen) zusammengezählt werden.

Mit =COUNT($F$2:$F$7=3)+($G$2:$G$7=3) schaffe ich es auch die korrekte Zahl zu ermitteln, nur bekomme ich die zusätzliche Bedingung, nämlich, dass B2:B7 und C2:C7 = "Team1" sein soll EINFACH NICHT HIN!!!

Bitte um Hilfe
I.ü. ist Eure Seite ausgezeichnet; habe mir schon so manche Formel herausgeguckt. Weiter so!

Gruss,
Martin

  

Formel #273?
von: Martin
Geschrieben am: 07.06.2002 - 16:38:08

Hallo WF,

mein Problem sollte mit Eurer Formel #273 zu lösen sein, klappt bei mir aber nicht!?

Ich denke aber auf dem richtigen Weg zu sein, oder?
Summenprodukt klappt i.ü. dann nicht, wenn Leerzellen vorhanden sind. Deshalb muss ich wohl auf die andere Formel zurückgreifen.

Gruss,
Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Martixformeln, SUMMEWENN und mehrere Spalten?"