Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Werkzeug
BildScreenshot zu Werkzeug Werkzeug-Seite mit Beispielarbeitsmappe aufrufen

Spalte nach gleichen Teilen/Varianten durchsuchen

Betrifft: Spalte nach gleichen Teilen/Varianten durchsuchen von: Björn
Geschrieben am: 27.08.2014 09:25:07

Einen schönen guten Morgen,

Ich versuche mich gerade daran einige Exceltabellen zu aktualisieren und zu modifizieren.
Und zwar stehe ich vor folgender Herausforderung (Beispieltabelle hinzugefügt).
https://www.herber.de/bbs/user/92311.xlsx

Ich habe eine Spalte mit einigen hundert Teilenummern und der zügehörigen Anzahl an benötigten Werkzeugen, um diese Teile herzustellen. Jetzt möchte ich einen simplen Durchschnitt Wkzg/Teil haben. Jetzt gibt es aber bei den Teilen teilweise Varianten (im Beispiel eingerahmt), bei denen sich diese speziellen Werkzeuge nicht unterscheiden (im letzten Arbeitsschritt natürlich schon, dieser wird hier aber nicht erfasst, weil andere Art von Werkzeug). Es werden also für die verschiedenen Varianten auch keine extra Wkzge benötigt. Bedeutet, ich habe 6 Varianten also 6 "verschiedene" Teile, benutze aber die gleichen Werkzeuge. In der Einzelansicht muss aber erkenntlich sein, wie viele Wkzge man pro Teil benötigt (hier im Beispiel: 5 Wkzge). Gesamt betrachtet sieht es jetzt allerdings so aus, dass man für diese 6 Teilevarianten insgesamt 30 Werkzeuge benötigt, obwohl es nur 5 sind in der Realität. Wie kann ich die Spalte Teilenummer abfragen, dass mir die Anzahl an den Varianten und der dazugehörigen Anzahl an Wkzgen ausgegeben wird um so das Verhältnis von allen Teilen zu Werkzeugen zu erhalten. Die Teilenummer der Varianten unterscheidet sich lediglich in einem zusätzlichen Buchstaben.

Summe(Werkzeuge aller Teile minus Summe Werkzeuge Varianten [erste Abfrage?]) plus Summe (Werzeuge Varianten geteilt durch Anzahl Varianten [zweite Abfrage?]) Ergebnis geteilt durch Anzahl Teile:

- Summe(Werkzeuge aller Teile minus Summe Werkzeuge Varianten [erste Abfrage?]) : 61 - 30 = 31

- Summe (Werzeuge Varianten geteilt durch Anzahl Varianten [zweite Abfrage?]): 30 / 6 = 5

- Ergebnis geteilt durch Anzahl Teile : 31 + 5 = 36 / 19, Endergebnis = 1,89 Wkzg/Teil

Ich hoffe mir kann jemand helfen und schon mal ein Dankeschön, für das Durchlesen dieses ellenlangen Textes.

Grüße
Björn

  

Betrifft: AW: Spalte nach gleichen Teilen/Varianten durchsuchen von: Rudi Maintaire
Geschrieben am: 27.08.2014 10:56:14

Hallo,
so?

ABCDEFGHI
3TeilenummerAnzahl Werkzeuge Durchschnittliche Anzahl Wkzg/Teil  Anzahl Teile Ohne Varianten Wkzg/Teil
4xxx.xxx.1231 1     
5xxx.xxx.3452 2     
6xxx.xxx.5673 3     
7xxx.xxx.7894 4     
8xxx.123.7775 0,833333333     
9xxx.123.777A5 0,833333333     
10xxx.123.777B550,8333333335,00 19,00 1,89
11xxx.123.777C5 0,833333333     
12xxx.123.777D5 0,833333333     
13xxx.123.777E5 0,833333333     
14xxx.xxx.1345 5     
15xxx.xxx.2453 3     
16xxx.xxx.5551 1     
17xxx.xxx.4672 2     
18xxx.xxx.5781 1     
19xxx.xxx.6893 3     
20xxx.xxx.7903 3     
21xxx.xxx.8902 2     
22xxx.xxx.9901 1     

ZelleFormel
D4=B4/SUMMENPRODUKT((LINKS($A$4:$A$22;11)=LINKS(A4;11))*1)
E10=SUMME(D8:D13)
G10=ANZAHL2(A4:A22)
I10=SUMME(D4:D22)/ANZAHL2(A4:A22)


Gruß
Rudi


  

Betrifft: AW: Spalte nach gleichen Teilen/Varianten durchsuchen von: Björn
Geschrieben am: 27.08.2014 11:29:20

ähm, ich glaube das könnte passen, versuche es noch nachzuvollziehen :)
...
Ich glaube ich habe es verstanden...

Ich werde das mal so anpassen und hoffentlich morgen ein Feedback geben. Ich danke dir Rudi und einen schönen Tag noch.

Grüße
Björn


  

Betrifft: GELÖST von: Björn
Geschrieben am: 28.08.2014 14:08:32

Danke noch mal an Rudi, konnte jetzt alles entsprechend anwenden und das Problem hat sich dadurch beseititgt.


 

Beiträge aus den Excel-Beispielen zum Thema "Spalte nach gleichen Teilen/Varianten durchsuchen"