Microsoft Excel

Herbers Excel/VBA-Archiv

Wert suchen und übernehmen

Betrifft: Wert suchen und übernehmen
von: Werner Golla
Geschrieben am: 22.04.2003 - 13:04:56

Hallo Leute,
auf der Suche nach einer Problemlösung bin ich über dieses Forum "gestolpert", und möchte sogleich mein Excel-Problem vortragen, in der Hoffnung dass mir jemand weiterhelfen kann.

In Tabellenblatt-1 wird durch Addition und Subtraktion ein Wert X ermittelt.

Tabellenblatt-2 übernimmt diesen ermittelten Wert automatisch. Zur weiteren Berechnung wird in Tabellenblatt 2 ein Prozentsatz benötigt, welche im Tabellenblatt-3 manuell gesucht und manuell in Tabellenblatt-2 übertragen wird.

In Tabelleblatt 3 befinden sich Ziffern von 1 bis 21.000 in mehreren Spalten.
Pro spalte 366 Felder.
Spalte 1 Feld 1 = Ziffer 1
Spalte 1 Feld 2 = Ziffer 2 usw.

Spalte 3 Feld 367 = Ziffer 367
Spalte 3 Feld 368 = Ziffer 368 usw.

Rechts neben jeder Ziffernspalte/-feld befindet sich eine Spalte/Feld mit jeweils einem Prozentwert.

Nun möchte ich, dass der Prozentsatz welcher der Ziffer X zugeordnet ist, automatisch in der Tabelle des Tabellenblattes 3 gesucht wird, und automatisch in das für diesen Prozentsatz vorgesehene Feld des Tabellenblattes 2 übernommen wird.

Wie muss die Formel aussehen, wenn es denn geht?

AufWunsch sende ich euch die Tabelle zu.
Bin neu in diesem Forum und habe keine Ahnung wie ich eine Datei anhängen kann.

flippig-freche Landhausmodengrüße aus dem Chiemgau vom
Werner
Schneider von Endorf




  

Re: Wert suchen und übernehmen
von: AndreasG
Geschrieben am: 22.04.2003 - 13:11:37

Hallo Werner,

ohne mich jetzt detailliert mit deiner Tabennstruktur beschäftigt zu haben hört sich das stark nach der Formel SVERWEIS an.
Schau in der Hilfe nach der Syntax...

Grüße

Andreas

  

Re: Wert suchen und übernehmen
von: Panicman
Geschrieben am: 22.04.2003 - 13:31:16

Hallo Werner,

Andreas hat schon recht, müßte mit Sverweis() funktionieren. Es gibt nur ein Problem. Wie kann man ermitteln, in welcher Spalte man die Ziffer X suchen soll. D.h. mit welcher Logik sind die Ziffern den Spalten zugeordnet ?

Gruß
Holger

  

Re: Wert suchen und übernehmen
von: xxx
Geschrieben am: 22.04.2003 - 13:32:50

Hallo,
unter der Voraussetzung, dass dein Wert X in Tabelle2 in A1 steht und genau mit deinen Werten in Tab3 übereinstimmt:
=SVERWEIS(A1;BEREICH.VERSCHIEBEN(Tabelle3!A1:B366;0;GANZZAHL(A1/366)*2);2;FALSCH)
liefert dir den zugehörigen Prozentwert.

Gruß

  

genial, wieder was gelernt !!_ o.T.
von: Panicman
Geschrieben am: 22.04.2003 - 13:43:10



  

Danke für das Lob!
von: xxx
Geschrieben am: 22.04.2003 - 13:50:05

Gruss
Udo

  

Re: Wert suchen und übernehmen
von: Wahnsinn...
Geschrieben am: 22.04.2003 - 14:48:00

...so schnell bekommt man in diesem Forum eine antwort.

vielen Danke.

Aber bei mir klappt das nicht.
Vielleicht könnt ihr mir „auf die Sprünge“ helfen

Der Wert (Beispiel: 1127), dem ein Prozentsatz zugeordnet werden soll, befindet sich im Tabellenblatt1 in Feld I/41. Nachdem dieser Wert in das Tabellenblatt2 übernommen wurde (automatisch +Tabelle1!I41 ) befindet er sich dort in Feld D/16.
In Feld D/17 soll nun ein Prozentwert aus dem Tabellenblatt3 angezeigt werden.
Dieser Prozentwert befindet sich genau neben dem Feld, dessen Inhalt identisch (1127) ist mit dem Inhalt von Feld D/16 des Tabellenblattes2 (bzw. I/41 – Tabellenblatt1).

Beispiel aus dem Tabellenblatt3
Spalten/Zeilen gehen bis DJ/367
Spalte A Ziffern 1 bis 366
Spalte B Prozentwerte
Spalte C Ziffern 367 bis 732
spalte B Prozentwerte
usw.

A B C D E F G H
1 20,49% 367 24,88% 733 29,37% 1099 33,66%
2 20,50% 368 24,89% 734 29,38% 1100 33,67%
3 20,51% 369 24,90% 735 29,39% 1101 33,68%
4 20,53% 370 24,92% 736 29,41% 1102 33,70%
5 20,54% 371 24,93% 737 29,42% 1103 33,71%
6 20,55% 372 24,94% 738 29,43% 1104 33,72%
7 20,56% 373 24,95% 739 29,44% 1105 33,73%
8 20,57% 374 24,97% 740 29,45% 1106 33,74%
9 20,59% 375 24,98% 741 29,46% 1107 33,76%
10 20,60% 376 24,99% 742 29,48% 1108 33,77%
11 20,61% 377 25,00% 743 29,49% 1109 33,78%
12 20,62% 378 25,01% 744 29,50% 1110 33,79%
13 20,63% 379 25,03% 745 29,51% 1111 33,80%
14 20,65% 380 25,04% 746 29,52% 1112 33,82%
15 20,66% 381 25,05% 747 29,53% 1113 33,83%
16 20,67% 382 25,06% 748 29,55% 1114 33,84%
17 20,68% 383 25,08% 749 29,56% 1115 33,85%
18 20,69% 384 25,09% 750 29,57% 1116 33,86%
19 20,71% 385 25,10% 751 29,58% 1117 33,88%
20 20,72% 386 25,11% 752 29,59% 1118 33,89%
21 20,73% 387 25,13% 753 29,60% 1119 33,90%
22 20,74% 388 25,14% 754 29,62% 1120 33,91%
23 20,75% 389 25,15% 755 29,63% 1121 33,92%
24 20,77% 390 25,16% 756 29,64% 1122 33,94%
25 20,78% 391 25,17% 757 29,65% 1123 33,95%
26 20,79% 392 25,19% 758 29,66% 1124 33,96%
27 20,80% 393 25,20% 759 29,67% 1125 33,97%
28 20,81% 394 25,21% 760 29,69% 1126 33,98%
29 20,83% 395 25,22% 761 29,70% 1127 34,00%
30 20,84% 396 25,24% 762 29,71% 1128 34,01%
31 20,85% 397 25,25% 763 29,72% 1129 34,02%
32 20,86% 398 25,26% 764 29,73% 1130 34,03%
33 20,87% 399 25,27% 765 29,75% 1131 34,04%
34 20,89% 400 25,28% 766 29,76% 1132 34,06%
Jeweils Zeile 2 bis 367 durchnummeriert bis 20862 = DJ/367

Wenn der Wert im Tabellenblatt2 (aus Tabellenblatt1 automatisch übernommen) 1127 betragen würde (hier G/29), soll dieser im Tabellenblatt3 gefunden werden, und der nebenanstehende Prozentsatz (hier 34,00% H/29) automatisch in das Feld G/16 von Tabellenblatt3 angezeigt werden. Der Prozentsatz soll aber im Tabellenblatt3 erhalten bleiben.

Danke
werner




  

Re: Wert suchen und übernehmen
von: Martin Beck
Geschrieben am: 22.04.2003 - 15:20:11

Hallo Werner,

schreibe in Zelle D17 der Tabelle2 folgende Formel:

=INDIREKT("Tabelle3!"&ADRESSE(REST(Tabelle3!D16;366);2*GANZZAHL(Tabelle3!D16/366)+2;4))

Du würdest Dir aber das Leben leichter machen, wenn Du in Tabelle3 untereinander in Spalte A alle 21000 Zahlen und in Spalte B alle dazugehörigen Prozentwerte schreiben würdest. Dann könnte man das Ganze einfach so lösen:

=SVERWEIS(D16;Tabelle3!$A$1:$B$21000;2;FALSCH)

Gruß
Martin Beck


 

Beiträge aus den Excel-Beispielen zum Thema "Wert suchen und übernehmen"