Tabellen mit Verweise duplizieren

Bild

Betrifft: Tabellen mit Verweise duplizieren
von: Thorsten W.
Geschrieben am: 24.09.2003 21:17:00

Hi Leute,

stehe wieder mal vor einer Aufgabe, deren Lösung ich nicht mächtig bin.
Wer kann helfen?

Ich möchte in eine Excel-Datei 100 Tabellen einfügen.
Die Tabellenblätter werden kurz '0'bis'99'genannt.
'0' ist Vorgabe und Auswertung
'1' bis '99' sind identische Formulare

u.a. stehen in '1' folgende Formeln

"I12" =WENN(('0'!D3<>0); '0'!D3;"")
"I13" =WENN(('0'!E3<>0); '0'!E3;"")
"I14" =WENN(('0'!F3<>0); '0'!F3;"")
"I15" =WENN(('0'!G3<>0); '0'!G3;"")
"H17" =WENN(('0'!H3<>0); '0'!H3;"")
"I17" =WENN(('0'!I3<>0); '0'!I3;"")
"J17" =WENN(('0'!J3<>0); '0'!J3;"")
"Q12" =WENN(('0'!Q3<>0); '0'!Q3;"")
"Q13" =WENN(('0'!R3<>0); '0'!R3;"")
"Q14" =WENN(('0'!S3<>0); '0'!S3;"")
"Q15" =WENN(('0'!T3<>0); '0'!T3;"")
"P17" =WENN(('0'!U3<>0); '0'!U3;"")
"Q17" =WENN(('0'!V3<>0); '0'!V3;"")
"R17" =WENN(('0'!W3<>0); '0'!W3;"")
"I20" =WENN(('0'!CC3<>0); '0'!CC3;"")
"K20" =WENN(('0'!P3<>0); '0'!P3;"")
"R20" =WENN(ISTLEER('0'!Q3);"";Z354)
"S20" =WENN(('0'!AC3<>0); '0'!AC3;"")

Diese Tabelle muß ich also 98x kopieren / einfügen.
Beim einfügen in die nächste Tabelle soll dann jeweils
der Zellenwert gegenüber der voherigen Tabelle um 1 erhöht
werden (außer bei "z354" - dieser Wert bleibt immer gleich).

Beim Kopieren der '1' müsste beim Einfügen in '2' folgende
Formeln stehen

"I12" =WENN(('0'!D4<>0); '0'!D4;"")
"I13" =WENN(('0'!E4<>0); '0'!E4;"")
u.s.w.

Bild


Betrifft: AW: Tabellen mit Verweise duplizieren
von: Panicman
Geschrieben am: 24.09.2003 21:56:41

Hallo Thorsten,

wenn ich dich richtig verstanden habe, sollte das so gehen:

I12 =WENN(INDIREKT("'0'!D"&WERT(TEIL(ZELLE("dateiname";I12);FINDEN("]";ZELLE("dateiname";I12))+1;255))+2)<>0;INDIREKT("'0'!D"&WERT(TEIL(ZELLE("dateiname";I12);FINDEN("]";ZELLE("dateiname";I12))+1;255))+2);"")

Gruß
Holger

P.S. Die Mappe MUSS gespeichert sein !!!


Bild


Betrifft: AW: Tabellen mit Verweise duplizieren
von: Thorsten W.
Geschrieben am: 24.09.2003 22:15:34

Hallo Holger,

genau so woll`t ich es - genial

Danke und Gruß
Thorsten


Bild


Betrifft: Bitteschön, hab gern geholfen ! o.T.
von: Panicman
Geschrieben am: 24.09.2003 22:23:41




 Bild

Beiträge aus den Excel-Beispielen zum Thema " Tabellen mit Verweise duplizieren"