Aus Matrix 1 auf Wert in Matrix 2 Verweisen?!

Bild

Betrifft: Aus Matrix 1 auf Wert in Matrix 2 Verweisen?! von: Sebastian Brüchert
Geschrieben am: 16.03.2005 13:58:17

Hallo Leute,

ich hab folgendes Problem. Ich habe eine Arbeitsmappe mit einer Matrix auf dem Tabellenblatt "Spezifikationen", einer Matrix auf dem Tabellenblatt "Preistabelle" und ein Tabellenblatt "Kalkulation".

Nun möchte ich auf meinem Tabellenblatt "Kalkulation" Mehrpreise vom Tabellenblatt "Preistabelle" unter beachtung von matrix "spezifikation" beziehen.

Also der Nutzer gibt bei der Spezifikation den Typen "K21R 56 G2" und das Zusatzteil "M200" an und in der Kalkulation erscheint der Mehrpreis für diese Kombination.

Schaut bitte mal auf die Arbeitsmappe https://www.herber.de/bbs/user/19738.xls
, daraus gehen die Matrizen besser hervor.

Ich hatte die Idee mit Sverweis und ner if Verzweigung: wenn Zelle D7 = 1 dann Wert in Kalkulation...

Kann mir da jemand nen Tipp geben?

Bild


Betrifft: AW: Aus Matrix 1 auf Wert in Matrix 2 Verweisen?! von: r.sch.
Geschrieben am: 16.03.2005 20:41:36

Hej Sebastian,

mit dieser Formel kommst du unter bestimmten Bedingungen weiter:

=WENN('19738.xls'!M_012_spez=1;'19738.xls'!M_012_preis;"")

dabei habe ich den Bereich Spezifikation d6:d11 mit M_012_spez benannt, und den Bereich Preistabelle d6:d11 M_012_preis.

1. Voraussetzung: Weil ich mit der Namensgebung nicht nach der Zeile suchen will, müssen die Tabellen von den Zeilenpositionen gleich aufgebaut sein.
2. Leider kannst du nicht 'seitwärts' kopieren, da mußt du jeweils den neuen Spaltennamen (M_200...) einfügen, nach 'unten' kannst du kopieren, solang, wie du den Bereich für die jeweiligen Namen definiert hast.
3. Es müssen die Daten für Typ und Art in allen Tabellen in der entsprechend selben Zeile stehen.


Gruß aus 'm Vorharz
Reinhard

PS.: ich hab' mal mit Index und Serweis experimentiert, bin aber (noch) zu keinem Ergebnis gekommen. Irgendwie hat mich dein Problem an s. Anhang erinnert, hab' aber leider die Seuche (Grippe) und kann nicht so ganz klar denken.
https://www.herber.de/bbs/user/19768.txt


Bild


Betrifft: AW: Aus Matrix 1 auf Wert in Matrix 2 Verweisen?! von: r.sch.
Geschrieben am: 17.03.2005 16:37:47

Hej Sebastian,

ich habe noch ein bißchen nachgedacht und bin zu folgender Lösung gekommen.
Dazu habe ich folgende Bereiche mit Namen versehen: Spezifikation B6:F6 "Art"; C7:F11 "Typ"; Kalkulation B6:G6 "k_art"; C7:C11 "k_typ"; Preistabelle B5:F5 "p_art";B6:B10 "p_typ" und B6:F10 "p_werte". Die Bereiche kannst du deinen Gegebenheiten anpassen.
In Zelle E7 (Kalkulation) steht die Formel
=WENN(SVERWEIS(k_typ;typ;VERGLEICH(k_art;Art;0)-1;1)=1;SVERWEIS(k_typ;p_werte;VERGLEICH(k_art;p_art;0));)

Diese kannst du jetzt in den Bereich kopieren. Bedenke die Bedingung von SVERWEIS: aufsteigend sortieren!

Gruß aus 'm Vorharz
Reinhard


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Aus Matrix 1 auf Wert in Matrix 2 Verweisen?!"