Herbers Excel-Forum - das Archiv

Variable SVerweise

Bild

Betrifft: Variable SVerweise
von: Christian

Geschrieben am: 15.02.2005 10:31:16
Hallo Leute,
da ich ne grooooße Excel-Datei mit vielen SVerweisen habe (die sich ständig wiederholen) bei denen immer mal wieder der Pfad zu der Matrix geändert werden muss, will ich, dass der Pfas aus einer Zelle eingelesen wird, damit ich das nur einmal statt 1000mal ändern muss.
Leider gibt er bei einerm normalen Verweis #NV aus was ja kein Wunder ist, da er dann die Zelle für die Matrix hält.
Wie bekomme ich ihn nun dazu es richtig einzulesen und als Argument zu verwenden?
Gruß und Danke,
Christian
Bild

Betrifft: AW: Variable SVerweise
von: Galenzo
Geschrieben am: 15.02.2005 10:36:25
indem du die Funktion INDIREKT verwendest
so: =SVERWEIS(F2;INDIREKT(G1);1)
in G1 steht dabei hier z.B: A1:D4 - also der Matrix-Bezug als Text
Bild

Betrifft: AW: Variable SVerweise
von: Christian
Geschrieben am: 15.02.2005 11:23:01
Ja danke,
leide arbeite ich Dateiübergreifend und diese Dateien könne nicht jedesmal geöffnet werden, damit das funktioniert.
Evtl. noch jemand eine andere Lösung?
 Bild
Excel-Beispiele zum Thema "Variable SVerweise"
Variablenübergabe in andere Arbeitsmappen Text aus Textbox in Variable
Einlesen von Zellinhalten in Variablen Variable in Formel einbauen
Variable in Excel-Formel einbauen. Text aus UserForm-Textbox in Variable einlesen
Variable in Zwischenablage übernehmen Variablen in einer temporären Textdatei zwischenspeichern
Zellinhalte in Verbindung mit Variablen in Textdatei schreiben Feldvariable auf Inhalt testen