Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN Zahl zwischen X und Y

Betrifft: SUMMEWENN Zahl zwischen X und Y von: Andi Scheer
Geschrieben am: 10.09.2004 11:07:43

hi

ich habe 2 spalten A und B.
Ich möchte nun in C1 die Summe von A1 bis A50 bilden, wenn jeweils in der Spalte B eine Zahl zwischen 100 und 200 steht.

Wenn in der Spalte B irgendwo von B1 bis B50 etwa 99 steht soll er die benachbarte Zelle in der Spalte A nicht summieren.

SUMMEWENN mit der Bedingung grössergleich 100 MINUS SUMMEWENN mit der Bedingung grösser 200 funktioniert für alle Werte von 100 bis 200. Wenn ich allerdings z.b. 99 eintrage, wird trotzdem summiert.

Hat wer ne Idee, oder kann man in der Bedingung einen Bereich eingeben ??

thx

  


Betrifft: AW: SUMMEWENN Zahl zwischen X und Y von: Mac4
Geschrieben am: 10.09.2004 11:18:58

Hallo Andi,

das kann ich nicht so ganz nachvollziehen. Ich habe Dir mal ein Beispiel gemacht:
https://www.herber.de/bbs/user/10743.xls

Marc (aus Köln)


  


Betrifft: AW: SUMMEWENN Zahl zwischen X und Y von: Andi Scheer
Geschrieben am: 10.09.2004 11:30:18

*arghhhh*

meine Formel hat "einige" Spalten mehr ..
nachdem ich deines durchgegangen bin, stellte ich fest dass nach dem minus die klammer fehlt .. ;-(

thx auf jeden fall 8)


  


Betrifft: AW: SUMMEWENN Zahl zwischen X und Y von: M@x
Geschrieben am: 10.09.2004 11:29:17

Hi Andi
zBsp. so
=SUMMENPRODUKT((A10:A50)*(B1:B50>99)*(B1:B50<201))

Gruss

M@x


  


Betrifft: AW: SUMMEWENN Zahl zwischen X und Y von: Andi Scheer
Geschrieben am: 10.09.2004 11:52:20

das ist mal ne praktische formel .. :-]
besten dank m@x


  


Betrifft: AW: SUMMEWENN Zahl zwischen X und Y von: M@x
Geschrieben am: 10.09.2004 11:57:12

Hi Andi,
hoffe, du hast den Schreibfehler ausgebessert:
=SUMMENPRODUKT((A1:A50)*(B1:B50>99)*(B1:B50<201))
Gruss

M@x


  


Betrifft: AW: SUMMEWENN Zahl zwischen X und Y von: Andi Scheer
Geschrieben am: 10.09.2004 12:08:15

klar hab ich, ..
da bei mir mehrere spalten mit grösserem zellenbereich involviert sind

nochmals danke


 

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN Zahl zwischen X und Y"