Herbers Excel-Forum - das Archiv

Problem mit SUMMEWENN und MONAT()



Excel-Version: 2000
nach unten

Betrifft: Problem mit SUMMEWENN und MONAT()
von: Marcus


Geschrieben am: 03.05.2002 - 10:53:28

Hallo,

ich habe eine Liste, in der in SPalte A das DAtum steht.
In Spalte J stehen Zahlen, die ich addieren möchte.
Nun habe ich eine Zelle, in der alle Zahlen des heutigen Tages addiert werden:

=SUMMEWENN(Tabelle2!A1:A65536;HEUTE();Tabelle2!J1:J65536)

Das klappt auch. Nun möchte ich, dass in einer anderen Zelle alle Zahlen des aktuellen Monats addiert werden:

=SUMMEWENN(Tabelle2!A1:A65536;MONAT(HEUTE());Tabelle2!J1:J65536)

Kann mir jemand sagen, warum das nicht geht. Ergebnis ist immer 0 ... ?!?!

Danke !

nach oben   nach unten

Re: Problem mit SUMMEWENN und MONAT()
von: Holger Levetzow


Geschrieben am: 03.05.2002 - 11:07:56

versuche es mit einer matrixformel: ohne {} eingeben und mit Strg+Umsch+Enter abschließen). Allerdings kann man dabei nicht die ganze Spalte nehmen, sondern höchsten A1:A65535 besser weniger:Zeit)

{=SUMME(WENN(MONAT(A1:A4)=MONAT(HEUTE());Tabelle2!J1:J4;0))}

Holger

nach oben   nach unten

Du hast Tabelle2! vergessen
von: WF


Geschrieben am: 03.05.2002 - 11:19:17

Hi,

{=SUMME((MONAT(Tabelle2!A1:A1000)=MONAT(HEUTE()))*Tabelle2!J1:J1000)}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite

nach oben   nach unten

Re: Du hast Tabelle2! vergessen
von: Holger Levetzow
Geschrieben am: 03.05.2002 - 11:45:14

stimmt, aber sonst geht die Lsg.

{=SUMME(WENN(MONAT(Tabelle2!A1:A4)=MONAT(HEUTE());Tabelle2!J1:J4;0))}

nach oben   nach unten

Danke Euch ! Klappt alles !!
von: Marcus
Geschrieben am: 03.05.2002 - 12:04:00


 nach oben

Excel-Beispiele zum Thema "Problem mit SUMMEWENN und MONAT()"
Verschnittproblem mit Solver lösen Beispiel für die Anwendung der SUMMEWENN-FORMEL
SUMMEWENN-Funktion über mehrere Tabellenblätter SummeWenn-Summierung über mehrere Blätter
Benennen von Tabellenblättern mit Monatsnamen Monatsberechnung in der Rentenversicherung
Wieviel Wochen hat ein Monat? Datumsdifferenz in der Form "12 Jahre, 3 Monate, 4 Tage"
Werte eins bestimmten Monats summieren Anzahl eines bestimmten Wochentages im Monat