bedingtes Zählen von max Werten



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: bedingtes Zählen von max Werten
von: Hartwig
Geschrieben am: 14.05.2002 - 12:43:11

Hallo,

ich habe folgendes Problem und hoffe, daß mir einer von Euch helfen kann:
in einer Tabelle sind Werte aufgeführt, die je einmal pro Woche (= Spalte) pro Person (= Zeile) anfallen/aufgenommen werden.
In einer Spalte ganz rechts möchte ich für jede Person mittels einer Formel die Anzahl (nicht die Summe der Werte selbst) eintragen, wie oft Werte der Person Maximalwert im Vergleich mit den anderen Personen war. Der Maximalwert kann also für jede Woche in einer anderen Zeile stehen und auch immer ein anderer sein. Ich hoffe, das ist einigermaßen verständlich; ich füge ein Beispiel bei:

Personen : Woche1 : Woche2 : Woche3 ... SummeMax
Person1 : 19 : 21 : 13 ... 2
Person2 : 12 : 17 : 14 ... 1
Person3 : 11 : 10 : 12 ... 0
Person4 : 10 : 21 : 13 ... 1
... : ... : ... : ... ... ...

In der Spalte SummeMax soll die Formel stehen.

Für eine Lösung vielen dank im Voraus,
Hartwig







nach oben   nach unten

Re: bedingtes Zählen von max W
von: AxelG
Geschrieben am: 14.05.2002 - 13:10:03

Für jede Wochenspalte über bedingte Formatierung den jeweiligen Maximalwert farbig kennzeichnen lassen ( im Archiv nachsehen ). In der SpalteMax dann für die jeweilige Reihe die farbig gekennzeichneten Zellen zählen ( im Archiv nachsehen ). Die Spalte SummeMax kann dann auch über die bedingte Formatierung die jeweiligen nin/max Werte kennzeichnen.

In der Hoffnung geholfen zu haben,
Grüße

AxelG


nach oben   nach unten

Re: 2.te
von: AxelG
Geschrieben am: 14.05.2002 - 13:30:15

Schau mal auf Deine Festplatte, unter:
C:\Programme\Microsoft Office\Office\Samples
könnte eine Datei : SAMPLES.XLS sein,
dort ist auch ein wenig zur bedingten Formatierung

AxelG

nach oben   nach unten

Re: 2.te
von: hartwig
Geschrieben am: 14.05.2002 - 15:35:55

Hallo Axel,
vielen Dank; die Formatierung steht, leider habe ich nichts passendes bzgl. des Zählens im Archiv gefunden. Bei allem, was da war, wurde darauf hingewiesen, daß es nicht mit "Bedingter Formatierung" funktioniert.
Ferner waren das alles Makros, ich würde (eine) Funktion(en) vorziehen.
In der Samples.xls steht nur, wie man bedingt formatiert.
Grusz
Hartwig


nach oben   nach unten

Re: 2.te
von: AxelG
Geschrieben am: 14.05.2002 - 15:39:53

Erstelle Dir folgende Funktion:
Function countcolorf(rng As Range, icolor As Integer)
Dim rngact As Range
Dim icount As Integer
For Each rngact In rng.Cells
If rngact.Font.ColorIndex = icolor And _
Not IsEmpty(rngact) Then
fcount = fcount + 1
End If
Next rngact
countcolorf = fcount
End Function

In die Zelle dann:
=countcolorf(Zelle:Zelle;Farbe)

viel Erfolg,
Grüße
AxelG

nach oben   nach unten

Re: bedingtes Zählen von max Werten
von: Josef B
Geschrieben am: 14.05.2002 - 22:12:24

Hallo Hartwig

Wenn du mit der Auswertung von vier Wochen zufrieden bist, dann hilft dir die Formel:
=N(B2=MAX(B$2:B$5))+N(C2=MAX(C$2:C$5))+N(D2=MAX(D$2:D$5))+N(E2=MAX(E$2:E$5))
Diese kannst du nach unten kopieren.
Die Werte stehen in meinem Beispiel in B2:E5.
Du kannst die Formel natülich auch noch um weitere Wochen ergänzen, aber dann wird diese schnell einmal unübersichtlich.

MfG Josef


nach oben   nach unten

Re: bedingtes Zählen von max Werten
von: Hartwig
Geschrieben am: 15.05.2002 - 10:16:05

Hallo Josef,
danke!
Es handelt sich um ca. 20 Wo., evtl. sogar bis Mitte dreißig.
Ich werd's mal probieren ...
Grusz
Hartwig

nach oben   nach unten

Re: 2.te
von: Hartwig
Geschrieben am: 15.05.2002 - 10:39:58

Hallo Axel,
habe die Formel erstellt, aber noch ein
Dim fcount as integer
eingefügt (unter den anderen Dim's) - weil er gemeckert hat. Sie funktioniert auch insofern, als sie einen Wert zurückgibt, nämlich "0". Ich habe mich bei dem integer-Wert für den colorindex an die xl-hilfe gehalten und die verschiedensten Farb/Index-Kombinationen ausprobiert. Das Ergebins ist immer "0" - obwohl Werte vorhanden sind!!
Kann es sein, daß das mit der bedingten Formatierung zusammenhängt, wie schon in anderen Beiträgen erwähnt?
Grusz
Hartwig



nach oben   nach unten

Re: bedingtes Zählen von max Werten
von: Martin Beck
Geschrieben am: 15.05.2002 - 10:58:28

Hallo Hartwig,

füge unterhalb der Daten eine Hilfszeile ein (in Deinem Beispiel Zeile 6), schreibe in B6 dann die Formel =MAX(B2:B5) und kopiere die Formel soweit wie nötig nach rechts.

In die Spalte mit den SummeMax-Werten (in Deinem Beispiel Spalte E) schreibst Du in E2 folgende Matrixformel unkopierst sie nach unten:

=SUMME(WENN(B2:D2=$B$6:$D$6;1;0))

Eingabe mit STRG-SHIFT-ENTER und nicht mit ENTER abschließen.

Hier noch einmal eine Tabelle zur Verdeutlichung:


MS Excel von Martin Beck an Hartwig
 ABCDEFGHIJ
1PersonenWoche1Woche2Woche3SummeMaxFormel_SummeMax    
2P11921132=SUMME(WENN(B2:D2=$B$6:$D$6;1;0))    
3P21217141     
4P31110120     
5P41021131     
6Max192114        
7Formel_Max=MAX(B2:B5)             


Gruß
Martin Beck



nach oben   nach unten

Re: bedingtes Zählen von max Werten
von: Hartwig
Geschrieben am: 15.05.2002 - 12:07:06

Hallo Martin,
Daumen hoch. Danke!
Grusz
Hartwig

nach oben   nach unten

Re: 2.te
von: AxelG
Geschrieben am: 16.05.2002 - 12:48:04

da haste Recht, bed. Formatierung wird nicht mitgezählt, ein Problem bei dem ich mir auch schon länger die Finger breche, wenn Du dafür eine Lösung auftreibst, bt. posten,

Grüße

AxelG



 nach oben

Beiträge aus den Excel-Beispielen zum Thema "bedingtes Zählen von max Werten"