Wenn Verschachtelung mit Text

Bild

Betrifft: Wenn Verschachtelung mit Text
von: Alex
Geschrieben am: 09.10.2015 16:12:54

Hallo zusammen,
vielleicht liegt es am Freitag, aber ich stehe einfach absolut auf dem Schlauch und hoffe auf Hilfe Eurerseits.
Folgendes: Ich habe 3 Spalten mit verschiedenen oder gleichen Zahlen.
Durch eine Wenn Funktion möchte ich in einer 4. Spalte folgende Auswertung:
1.Wenn in der Zeile Firmenname eine Zahl steht soll diese einfach so übernommen werden
2. Wenn Firmenname keine Zahl, dann schreibe die Zahl aus der Spalte Adresse mit dem Zusatz "Firma prüfen!"
3. Sind sowohl die Zeilen für Firmenname und Adresse leer, nehme die Spalte ID mit dem Zusatz "Firma und Adresse prüfen!"
Sollte dann wie folgt aussehen:
Userbild

Habe das ganze mit einer Wennschleife versucht, scheitere jedoch kläglich!
=WENN(A2>0;A2;WENN(C2>0;C2 & "Firma prüfen!";WENN(SUMME(A2;C2)=0; B2 & "Firma und Adresse prüfen!";""))
Würde mich über Hilfe sehr freuen!
Liebe Grüße
Alex


Bild

Betrifft: Klammer rechts fehlt, außerdem,
von: Michael
Geschrieben am: 09.10.2015 16:56:27
Alex,
läßt sich die Formel vereinfachen:

=WENN(A6>0;A6;WENN(C6>0;C6 & " Firma prüfen!"; B6 & " Firma und Adresse prüfen!"))
Der letzte "sonst"-Zweig ergibt sich "automatisch" aus den vorangegangenen Vergleichen und wird angezeigt, wenn sowohl A6 als auch C6 nicht "größer 0" sind.
Falls sich wirklich mal ein Leerzeichen oder sowas reinverirrt, würde ich lieber abfragen mit
A6<>""
Schöne Grüße,
Michael

Bild

Betrifft: AW: Klammer rechts fehlt, außerdem,
von: Alex
Geschrieben am: 12.10.2015 14:32:39
Bestens! Mit A6<>"" funktioniert es tatsächlich.
Ich bedanke mich!

Bild

Betrifft: gerne, vielen Dank für die Rückmeldung owT
von: Michael
Geschrieben am: 12.10.2015 17:56:57


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Werte mit Vorjahr vergleichen"