Vergleich von 2 spalten

Bild

Betrifft: Vergleich von 2 spalten
von: Yves
Geschrieben am: 17.02.2005 14:04:02
Halli Hallo
Ich habe eine kleine Frage. Ich habe ein Excel File mit nur zwei spalten. In Spalte A habe ich etwa 2000 Artikelnummern, in Spalte B habe ich etwa 10000 Artikelnummern. Nun möchte ich diese beiden Spalten miteinander vergleichen, sprich: welche Nummern sind in Spalte B, aber nicht in Spalte A vorhanden, und diese Irgendwie markieren. Wie stelle ich das am besten an ?
Vielen Dank für eure Hilfe
Grüsse
Yves

Bild

Betrifft: AW: Vergleich von 2 spalten
von: Oliver
Geschrieben am: 17.02.2005 14:09:06
Das funktioniert z.B. mit der Funktion Sverweis.
Bild

Betrifft: AW: Vergleich von 2 spalten
von: yves
Geschrieben am: 17.02.2005 14:16:51
Hallo Oliver
Vielen Dank für die superschnelle Info
Wie mache ich diesen Sverweis am besten ?
Bild

Betrifft: AW: Vergleich von 2 spalten
von: Oliver
Geschrieben am: 17.02.2005 14:22:59
Wenn du die Funktion noch nie benutzt hast, nimm am besten den Funktionsassistenten. Geh zum Beispiel in Zelle C2 und starte den Funktionsassistenten. Da musst du dann zuerst das Suchkriterium eingeben (z.B. A2), dann die Matrix, das ist der Bereich, in dem gesucht werden soll (z.B. B2:B100), dann der Spaltenindex, das ist die Nummer der Spalte der matrix, aus der der Wert zurückgegeben werden soll. In deinem Fall gibts nur eine Spalte, also 1. Zum Schluss bei Bereich_Verweis unbedingt 0 eingeben, dann wird nach 100%iger Übereinstimmung gesucht.
Bild

Betrifft: AW: Vergleich von 2 spalten
von: yves
Geschrieben am: 17.02.2005 14:34:38
Das habe ich nun gemacht und es hat auch wunderbar funktioniert.
Das Problem ist nur, dass er mir nun auch diejenigen Nummern angibtm, welche zwar in Spalte A und Spalte B vorhanden sind, die aber in einer anderen Zeile sind sprich die Nummer 3401628 ist einmal in A15 und einmal in B812. Die Artikelnummer ist also in beiden Spalten vorhanden und wird trotzdem angezeigt. Gibt es da auch noch einen Trick um das zu verhindern ?
Dank viel Mals
Bild

Betrifft: AW: Vergleich von 2 spalten
von: Hübi
Geschrieben am: 17.02.2005 17:11:43
Hi Yves,
versuch das einmal (entweder Formel oder Bed. Format.)
Tabelle1
 ABC
1Nummern 1Nummern 2nur in B
212 
327 
434 
549nur in B
6511nur in B
7644nur in B
871 
Formeln der Tabelle
C2 : =WENN(ISTZAHL(VERGLEICH(B2;A:A;0));"";"nur in B")
C3 : =WENN(ISTZAHL(VERGLEICH(B3;A:A;0));"";"nur in B")
C4 : =WENN(ISTZAHL(VERGLEICH(B4;A:A;0));"";"nur in B")
C5 : =WENN(ISTZAHL(VERGLEICH(B5;A:A;0));"";"nur in B")
C6 : =WENN(ISTZAHL(VERGLEICH(B6;A:A;0));"";"nur in B")
C7 : =WENN(ISTZAHL(VERGLEICH(B7;A:A;0));"";"nur in B")
C8 : =WENN(ISTZAHL(VERGLEICH(B8;A:A;0));"";"nur in B")
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
B21. / Formel ist =ISTNV(VERGLEICH(B2;A:A;0))Abc
B31. / Formel ist =ISTNV(VERGLEICH(B3;A:A;0))Abc
B41. / Formel ist =ISTNV(VERGLEICH(B4;A:A;0))Abc
B51. / Formel ist =ISTNV(VERGLEICH(B5;A:A;0))Abc
B61. / Formel ist =ISTNV(VERGLEICH(B6;A:A;0))Abc
B71. / Formel ist =ISTNV(VERGLEICH(B7;A:A;0))Abc
B81. / Formel ist =ISTNV(VERGLEICH(B8;A:A;0))Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hübi
Bild

Betrifft: AW: Vergleich von 2 spalten
von: Gert Seler
Geschrieben am: 17.02.2005 14:23:41
Hallo Yves,
das geht mit "Bedingter Formatierung".
Schau mal unter "Services" --->"Recherche" und gib "2 Spalten vergleichen" ein.
Dort werden auch andere Möglichkeiten gezeigt.
Siehe "Online-Hilfe" unter "Bedingte Formatierung" nach.
mfg
Gert
Es gibt nichts gutes, außer man tut es.
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Vergleich von 2 spalten"