Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

VBA / Makro Hilfe (kopieren einfügen)

VBA / Makro Hilfe (kopieren einfügen)
amintire
Guten Abend alle zusammen,
habe folgendes Problem (siehe Beispiel https://www.herber.de/bbs/user/79803.xls)
Es soll per Makro folgende Formel durchgeführt werden
(in Spalte A "=WENN(UND(S11="x";T11="x");"h";"")")
Und
Anzahl, Gelb markierten Bereich nach unten kopieren.
Beispiel S6 = 300, dann 300 x S11:Z38 kopieren und immer eine Zeile darunter einfügen
Bin für Hilfe Dankbar.
Gruß
Amintire

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: VBA / Makro Hilfe (kopieren einfügen)
15.04.2012 08:18:56
Josef

Hallo Amintire,
Sub koieren()
  Dim lngLast As Long
  
  With ActiveSheet
    If IsNumeric(.Range("S6")) Then
      .Range("S39:Z" & .Rows.Count) = ""
      .Range("A39:A" & .Rows.Count) = ""
      lngLast = .Range("S6") * 28 + 38
      If lngLast > 38 Then
        .Range("S11:Z38").AutoFill .Range("S11:Z" & lngLast)
        .Range("A11:A" & lngLast).Formula = "=IF(AND(S11=""x"",T11=""x""),""h"","""")"
      End If
    End If
  End With
  
End Sub



« Gruß Sepp »

Anzeige
AW: VBA / Makro Hilfe (kopieren einfügen)
15.04.2012 18:51:50
amintire
Hallo Sepp,
vielen Dank für deinen Lösungsvorschlag. Soweit klappt alles ganz gut.
Allerdings ist der gelb Markierte Bereich Variable.
Kann es per VBA Code erkannt werden, das wenn z.B. bei 16 Zeilen (in den Spalten) was drinsteht, er die Anzahl nimmt (den Bereich markieren) und eine Zeile darunter (wo frei ist) einfügt.
Sind es 17 Zeilen, dann 17 Zeilen (den Bereich mit Zeilen / Spalten) markieren und kopieren und darunter einfügen.
Gruß
Amintire
AW: VBA / Makro Hilfe (kopieren einfügen)
15.04.2012 19:16:44
Josef

Hallo Amintire,
so was sollte man halt immer gleich erwähnen!
Sub koieren()
  Dim lngLast As Long, lngRow As Long, lngCol As Long
  
  With ActiveSheet
    If IsNumeric(.Range("S6")) Then
      For lngCol = 19 To 26
        lngRow = Application.Max(lngRow, Application.Max(11, .Cells(.Rows.Count, lngCol).End(xlUp).Row))
      Next
      lngLast = .Range("S6") * lngRow + lngRow - (10 * .Range("S6"))
      If lngLast > 12 Then
        .Range("S11:Z" & lngRow).AutoFill .Range("S11:Z" & lngLast)
        .Range("A11:A" & lngLast).Formula = "=IF(AND(S11=""x"",T11=""x""),""h"","""")"
      End If
    End If
  End With
  
End Sub



« Gruß Sepp »

Anzeige

331 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige